Ripping Into .AAC Format

Nawlins

macrumors member
Original poster
Jun 9, 2003
80
0
Chicago
I just ripped a CD onto iTunes for the first time, and all the songs were imported as .mp3 files instead of .aac. Anyone know why this is occuring, and how I can fix it?

Thanks, Alex
 

Nawlins

macrumors member
Original poster
Jun 9, 2003
80
0
Chicago
Hmm, I hope this doesn't sound really dumb - when I clicked on the drop down menu for "Import Using," .AAC was not an option. The three options were MP3, AIFF, or WAV.

I'm confused.
 

Nawlins

macrumors member
Original poster
Jun 9, 2003
80
0
Chicago
One other issue - I was importing some Nirvana songs, and the song and album titles were not coming up correctly as they were being imported. It would say "Track 01" instead of "Smells Like Teen Spirit." Nirvana is pretty common, and even though their albums are from the early 90's, I would expect iTunes to recognize the songs.

Any thoughts?
 

LimeLite

macrumors 6502a
Mar 20, 2003
650
0
Los Angeles, Ca
Make sure you're using iTunes 4. Anything before that doesn't support AAC files. Once you have iTunes 4, go into the preferences, under the Importing button and choose AAC. As for the track names, it's not iTunes that recognizes it or not, it's the CDDB, a database which is accessed over the internet, meaning that your computer must be connected to the internet for it to pull up track titles and such. Good luck.
 

Nawlins

macrumors member
Original poster
Jun 9, 2003
80
0
Chicago
Thanks for the help - Do new Powerbooks come with iTunes 4, or do I have to download or purchase it?

I won't have internet access on my Mac for at least a few days because it won't work through the cable modem installed on our PC, and it wasn't dialing up properly (we have a 2nd phone line that we rarely use, but I get an error message saying "Server could not be found" when I try to load Internet Explorer by dialing up).

Alex
 

pEZ

macrumors 6502
Feb 2, 2003
384
0
Madison, Wisconsin
Also make sure you have Quicktime 6.3 - that will allow the AAC encoding.

Make sure you have all updates installed from Software Update, just a good tip.
 

patrick0brien

macrumors 68040
Oct 24, 2002
3,238
0
The West Loop
Originally posted by pEZ
Also make sure you have Quicktime 6.3 - that will allow the AAC encoding.
-Nawlins

pEZ stole my thunder :D

Yes, you need Quicktime 6.3 as the AAC codec resides withing that, not iTunes. iTunes merely borrows it.