Rise of Nations Gold keeps crashing...help plz?

Discussion in 'Games' started by unsung, Jul 3, 2006.

  1. unsung macrumors newbie

    Apr 15, 2004
    SW Chicago burbs
    It used to stop only about 5% of the time and usually about 45 mins into a game. Now I can't get two minutes into a game before it stops. I tried to reinstall but that didn't help, in fact it wouldn't let me install into my apps folder, I had to pick another.

    I've sent all the reports to Apple but I'm not sure if that helps or not. I have a quite lengthy crash report that I can post if it helps.

    Game is 100% original and not a copy.
  2. unsung thread starter macrumors newbie

    Apr 15, 2004
    SW Chicago burbs
  3. unsung thread starter macrumors newbie

    Apr 15, 2004
    SW Chicago burbs
    Date/Time: 2006-07-03 16:12:40 -0500
    OS Version: 10.3.9 (Build 7W98)
    Report Version: 2

    Command: Rise of Nations Gold
    Path: /Users/unsung/Rise of Nations Gold/Game/Rise of Nations Gold.app/Contents/MacOS/Rise of Nations Gold
    Version: 1.0 (1.0)
    PID: 433
    Thread: 5

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0x2e667260

    Thread 0:
    0 ...ple.CoreServices.CarbonCore 0x962f0fb0 OpenAComponent + 0xd8
    1 ...ple.CoreServices.CarbonCore 0x9630f0f8 OpenComponent + 0x14
    2 com.apple.audio.SoundManager 0x90491f50 MakeSoundComponentChain + 0x224
    3 ...dio.SoundManager.Components 0x086ae0e8 MixerDispatch + 0xcb8
    4 ...dio.SoundManager.Components 0x086adf70 MixerDispatch + 0xb40
    5 ...dio.SoundManager.Components 0x086ad58c MixerDispatch + 0x15c
    6 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    7 com.apple.audio.SoundManager 0x90491d1c SoundComponentAddSource + 0x28
    8 com.apple.audio.SoundManager 0x90494484 SetupSoundComponents + 0x1e8
    9 com.apple.audio.SoundManager 0x9049418c SoundConverterOpen + 0x70
    10 ....audio.toolbox.AudioToolbox 0x90545548 _Z22SoundConverterOpenProcPK18SoundComponentDataS1_PP20OpaqueSoundConverter + 0xb8
    11 ....audio.toolbox.AudioToolbox 0x9052bb34 _ZN15SoundMgrDecoder10InitializeERK14StreamDescPair + 0x12c
    12 ....audio.toolbox.AudioToolbox 0x9052b8ac _ZN15SoundMgrDecoderC4ER20ComponentDescriptionRK14StreamDescPairRl + 0x6c
    13 ....audio.toolbox.AudioToolbox 0x9052e494 _ZN22SoundMgrDecoderFactory19BuildConverterChainERK14StreamDescPairP19AudioConverterChainP19PCMConverterFactory + 0x174
    14 ....audio.toolbox.AudioToolbox 0x904d4d10 _ZN17ConverterRegistry15CreateConverterERK14StreamDescPairPP19AudioConverterChainmP21AudioClassDescription + 0x68
    15 ....audio.toolbox.AudioToolbox 0x904d466c AudioConverterNew + 0x164
    16 ...ickTimeComponents.component 0x97dfb490 AudioPrepCreate + 0x3a8
    17 ...ickTimeComponents.component 0x97df1d7c initAudioPrepAndContext + 0x540
    18 ...ickTimeComponents.component 0x97df6308 Sound3CCGetChunkCacheHandle + 0x5c
    19 ...ple.CoreServices.CarbonCore 0x962e80f8 CallComponentFunctionCommon + 0x458
    20 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    21 ...ickTimeComponents.component 0x985fca40 MediaCCGetChunkCacheHandle + 0x30
    22 ...ickTimeComponents.component 0x97dc2760 STMediaSTGetSampleData + 0x38
    23 ...ple.CoreServices.CarbonCore 0x962e81b0 CallComponentFunctionCommon + 0x510
    24 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    25 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    26 ...ickTimeComponents.component 0x985fba14 MediaSTGetSampleData + 0x40
    27 ...ickTimeComponents.component 0x97dc24ec STMediaGetSample + 0x38c
    28 ...ple.CoreServices.CarbonCore 0x962e8250 CallComponentFunctionCommon + 0x5b0
    29 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    30 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    31 com.apple.QuickTime 0x90ca95a8 MediaGetSample + 0x60
    32 com.apple.QuickTime 0x90ca9524 GetMediaSample_priv + 0x48
    33 com.apple.QuickTime 0x90ca94c4 GetMediaSample + 0x78
    34 com.macsoft.ron 0x000207b4 _Z32SoundConverterFillBufferDataProcPP18SoundComponentDataPv + 0x8c
    35 com.apple.audio.SoundManager 0x9049500c InvokeSoundConverterFillBufferDataUPP + 0x18
    36 com.apple.audio.SoundManager 0x90494e74 FillBufferPBMoreProc + 0x38
    37 com.apple.audio.SoundManager 0x90493c60 InvokeSoundParamUPP + 0x18
    38 ...dio.SoundManager.Components 0x086b1b2c BigEndian16DecompDispatch + 0x1e58
    39 ...dio.SoundManager.Components 0x086aeca0 SndSourceComponent + 0xd0
    40 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    41 com.apple.audio.SoundManager 0x90493c38 SoundComponentGetSourceData + 0x28
    42 ...ickTimeComponents.component 0x981f5dd0 MSADPCMSoundGetSourceData + 0x30
    43 ...ple.CoreServices.CarbonCore 0x962e80b4 CallComponentFunctionCommon + 0x414
    44 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    45 com.apple.audio.SoundManager 0x90493c38 SoundComponentGetSourceData + 0x28
    46 ...dio.SoundManager.Components 0x086b17a0 BigEndian16DecompDispatch + 0x1acc
    47 ...dio.SoundManager.Components 0x086b15d4 BigEndian16DecompDispatch + 0x1900
    48 ...dio.SoundManager.Components 0x086ae738 EqualizerDispatch + 0x118
    49 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    50 com.apple.audio.SoundManager 0x90493c38 SoundComponentGetSourceData + 0x28
    51 ...dio.SoundManager.Components 0x086b13e8 BigEndian16DecompDispatch + 0x1714
    52 ...dio.SoundManager.Components 0x086ae2d8 RateIntegerDispatch + 0x128
    53 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    54 com.apple.audio.SoundManager 0x90493c38 SoundComponentGetSourceData + 0x28
    55 ...dio.SoundManager.Components 0x086b1308 BigEndian16DecompDispatch + 0x1634
    56 ...dio.SoundManager.Components 0x086b1008 BigEndian16DecompDispatch + 0x1334
    57 ...dio.SoundManager.Components 0x086b0d00 BigEndian16DecompDispatch + 0x102c
    58 ...dio.SoundManager.Components 0x086b0be8 BigEndian16DecompDispatch + 0xf14
    59 ...dio.SoundManager.Components 0x086ad568 MixerDispatch + 0x138
    60 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    61 com.apple.audio.SoundManager 0x90493c38 SoundComponentGetSourceData + 0x28
    62 ...dio.SoundManager.Components 0x086b52dc BigEndian16CompDispatch + 0xf34
    63 ...dio.SoundManager.Components 0x086b5084 BigEndian16CompDispatch + 0xcdc
    64 ...dio.SoundManager.Components 0x086b44c0 BigEndian16CompDispatch + 0x118
    65 ...ple.CoreServices.CarbonCore 0x962e6e50 CallComponent + 0x10c
    66 com.apple.audio.SoundManager 0x90493c38 SoundComponentGetSourceData + 0x28
    67 com.apple.audio.SoundManager 0x904949bc SoundConverterFillBuffer + 0x170
    68 com.macsoft.ron 0x00020384 _Z15DecompressSoundPK6FSSpecPPPcP14ExtSoundHeader + 0x40c
    69 com.macsoft.ron 0x0001d674 _ZN17CQuickSoundPlayerC1EPc + 0x130
    70 com.macsoft.ron 0x000050c0 _ZN9DSSLSound14load_from_fileEv + 0x7c
    71 com.macsoft.ron 0x00005024 _ZN9DSSLSound4initERK6Stringi + 0xc8
    72 com.macsoft.ron 0x000bf6b0 _ZN5Sound4initERK6Stringi + 0x84
    73 com.macsoft.ron 0x0057beb0 _ZN8SoundRef5cacheEv + 0xb0
    74 com.macsoft.ron 0x00576d18 _ZN15SoundFileLookup16process_pendingsEm + 0x4c
    75 com.macsoft.ron 0x0012f06c _ZNK4Game11loop_renderEii + 0x78
    76 com.macsoft.ron 0x0012efac _ZN4Game4loopEv + 0x314
    77 com.macsoft.ron 0x0011f8cc _ZN4Game3runEi + 0x1674
    78 com.macsoft.ron 0x00124248 _ZN4Game8run_soloEiii + 0x1b24
    79 com.macsoft.ron 0x001366c4 _ZN4Main4mainEP11HINSTANCE__S1_Pci + 0x980
    80 com.macsoft.ron 0x00135d34 WinMain + 0x10
    81 com.macsoft.ron 0x00003ffc main + 0x210
    82 com.macsoft.ron 0x00003d3c _start + 0x188
    83 com.macsoft.ron 0x00003bb0 __code_start__ + 0x30

    Thread 5 Crashed:
    0 <<00000000>> 0x2e667260 0 + 0x2e667260
    1 ...ickTimeComponents.component 0x98615428 _ZN43AudioContextDeferredInterruptTaskEventQueue9PreRenderEmRK14AudioTimeStampmmRK15AudioBufferList + 0x22c
    2 ...ickTimeComponents.component 0x98613bc4 _ZN33AudioContextDeferredInterruptTask6RenderEmRK14AudioTimeStampmmRK15AudioBufferList + 0x28
    3 ...ickTimeComponents.component 0x98613cd4 _ZN40AudioContextDeferredInterruptTaskManager27DeferredInterruptTaskHelperEPvPmPK14AudioTimeStampmmP15AudioBufferList + 0x30
    4 ...pple.audio.units.Components 0x9188897c DefaultOutputAUEntry + 0x7180
    5 ...pple.audio.units.Components 0x91888050 DefaultOutputAUEntry + 0x6854
    6 com.apple.audio.CoreAudio 0x9720cb3c _ZN9IOADevice11CallIOProcsERK14AudioTimeStampS2_S2_ + 0x318
    7 com.apple.audio.CoreAudio 0x971fe860 _ZN10HPIOThread9PerformIOERK14AudioTimeStamp + 0x214
    8 com.apple.audio.CoreAudio 0x971fdde0 _ZN10HPIOThread8WorkLoopEv + 0x44c
    9 com.apple.audio.CoreAudio 0x971fe894 _ZN10HPIOThread11ThreadEntryEPS_ + 0x1c
    10 com.apple.audio.CoreAudio 0x971e02ec _ZN9CAPThread5EntryEPS_ + 0x30
    11 libSystem.B.dylib 0x90024990 _pthread_body + 0x28

    Thread 6:
    0 libSystem.B.dylib 0x900147e8 semaphore_wait_trap + 0x8
    1 ...ickTimeComponents.component 0x98280548 QTThreadWaitSignal + 0x64
    2 ...ickTimeComponents.component 0x97dfe440 audioprepThreadEntry + 0x4c
    3 ...ickTimeComponents.component 0x98280264 start_thread + 0x54
    4 libSystem.B.dylib 0x90024990 _pthread_body + 0x28

    PPC Thread State:
    srr0: 0x2e667260 srr1: 0x4200f030 vrsave: 0x00000000
    cr: 0x44024228 xer: 0x00000004 lr: 0x98616010 ctr: 0x2e667261
    r0: 0x2e667261 r1: 0xf02037e0 r2: 0x0000357b r3: 0x0aea8000
    r4: 0x0e8062d0 r5: 0x00000000 r6: 0x00000002 r7: 0x00000001
    r8: 0x0fe87cd0 r9: 0x98615fd4 r10: 0x0000000b r11: 0xa7ecdcb4
    r12: 0x2e667261 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
    r16: 0xf0203a10 r17: 0x00000000 r18: 0x00000200 r19: 0x00000001
    r20: 0xf0203c10 r21: 0x919278c0 r22: 0x00000200 r23: 0x0eadf8e8
    r24: 0xf0203a10 r25: 0x00000000 r26: 0x0eadf8e0 r27: 0x0ead1ef4
    r28: 0x0ead1da0 r29: 0x0eadf8e0 r30: 0x0ead1ef0 r31: 0x98615e88
  4. gvandusen macrumors newbie

    Jul 4, 2006
    Rise of Nations & 10.4.7 upgrade

    I have been using Rise of Nations with no problems until I upgraded to 10.4.7. Now it crashes as soon as you click on anything after the game opens.:mad:
  5. SpaceMagic macrumors 68000


    Oct 26, 2003
    Cardiff, Wales
    EXACTLY my problem. As soon at i installed 10.4.7, it no longer works.
  6. unsung thread starter macrumors newbie

    Apr 15, 2004
    SW Chicago burbs
    So how is it fixed? They are still selling the game for $50 so I would only think it should work.
  7. BlizzardBomb macrumors 68030


    Jun 15, 2005
    Mine too crashes on 10.4.7 as soon as you push a button. I can get around it by going on Conquer the World campaigns but it crashes 2 mins later anyway.

    MacSoft haven't released a single patch for this game since they released it. We need one now!
  8. SpaceMagic macrumors 68000


    Oct 26, 2003
    Cardiff, Wales
    I've posted the problem on Apple's boards too... but no one official is yet to reply.
  9. BlizzardBomb macrumors 68030


    Jun 15, 2005
    I've also sent an email to MacSoft to see if they will address the problem.
  10. AngeredTree macrumors member

    Jun 10, 2004
    Boston, MA
    I saw on apple's boards that the problem doesn't lie with 10.4.7 update, but rather with the quicktime 7.1.2 update, which came around the same time.

    Someone said they reverted to an older version, and got it to work. Although I was skeptical, I decided to give it a try, since apparently you can download an installer that removes quicktime 7.0.2+ (Including 7.1.2) and reverts to 7.0.1. This is an official apple reinstaller, so it seemed legit enough to give it a shot.

    I did it, restarted, and installed 7.0.4, which is the latest version other than 7.1.2 I could find. Then I restarted again, loaded up rise of nations, and guess what. It worked. Google around for the reverter, or go to apple's support website, you should find it.
  11. BlizzardBomb macrumors 68030


    Jun 15, 2005
    You genius! Here's the links.

    1) Quicktime 7 reinstaller

    2) Quicktime 7.0.4
  12. unsung thread starter macrumors newbie

    Apr 15, 2004
    SW Chicago burbs
    Ok, I downloaded the reinstaller and when I go to actually install it I get this message:

    "You cannot install this software on this volume. This disk is dimmed because it does not contain an appropriate version of Quicktime."

    I have 7.1.2, most everyone else seems to be getting it to work. What am I doing wrong?
  13. dpaanlka macrumors 601


    Nov 16, 2004
    This is a stupid work around the game should just work.
  14. BlizzardBomb macrumors 68030


    Jun 15, 2005
    They are working on a patch.

  15. jgmachine macrumors newbie

    Jul 14, 2006
    same problem

    I can't play the game either. It will crash randomly at different points, sometimes as soon as I open it, but usually while I'm navigating the main menu. I can't even start a new game. This is really pissing me off, you spend your money on a game to have it not be playable. There seems to be no possible way to get my quicktime version 7.1.2 back to an earlier version unless you are running OS 10.3.9.

    Does anyone know how to successfully uninstall quicktime? I tried deleting all of the files associated with quicktime, but when trying to install an older version of quicktime it would still detect 7.1.2 somehow not letting me install a previous version.
  16. dpaanlka macrumors 601


    Nov 16, 2004
    I just bought this game a week ago from the Apple Store. Now I can't even play it, and I'm not going to downgrade QuickTime because of a unsurprisingly malfunctioning Microsoft product.
  17. colinp macrumors member

    Jul 7, 2004
  18. jgmachine macrumors newbie

    Jul 14, 2006
    anyone know when these updates came out that are screwing up the game?
  19. neonart macrumors 65816


    Sep 4, 2002
    Near a Mac since 1993.
    Glad I found this! I was breaking my head with this problem. Removing prefrences, deleting modded ini files, and finally re-installing the game (along with all my settings :mad: ) to no avail.

    I think I'll just wait a little to see what happens, but it sucks hoover style.
  20. Macinflux macrumors newbie


    Jul 17, 2006
    Athens, Greece
    Yep me too

    Hi folks,

    Yes indeed I had the same situation with RoN Gold, moving from 10.3.9 to 10.4.7 and QT 7.1.2. I wrote to Macsoft support and got the same answer. They are working on it...! It's great that Macsoft are working on it, but sadly they are notoriously slow workers. I know pretty much for a fact ;) that they are working on Age of Empires III for Mac, but try and find it on their site! I personally will wait for a bit to see if they post any new patches for the game. But it may well be a long wait...
  21. fishinked macrumors newbie

    Jul 17, 2006
    Convoluted solution

    Well, it's not a perfect solution, but I was having the same problem as Unsung. I could not use the Quicktime reinstaller, because it does not work with Tiger.

    So, in case you haven't thought of this, and if you've got time on your hands, try reinstalling Tiger. I did this, my version came with QT 7.0. There's a custom install that will just rewrite the system software, while keeping your applications, etc.

    That did the trick. It just took awhile, at least an hour.
  22. BlizzardBomb macrumors 68030


    Jun 15, 2005
    Huh? AOEIII uses Havoc, and Havoc isn't on Macs?

    I'm running Tiger and the reinstaller worked perfectly.
  23. fishinked macrumors newbie

    Jul 17, 2006
    lucky y ou

    Good for you. I'm happy for you. I'm curious why it worked for you and not for others, such as myself. If you read the info on apple's site, it even says, it will only work with 10.3.9
  24. BlizzardBomb macrumors 68030


    Jun 15, 2005
    10.3.9 or higher. :)
  25. jgmachine macrumors newbie

    Jul 14, 2006
    Good news! I wrote macsoftgames and they wrote me back today with the following message:

    There'll be an update posted later today on our website that will fix the problem. Just keep your eye on the Rise of Nations support page at http://www.macsoftgames.com.

    So look for it later today :) Wasn't up there yet when I just looked, but should be there soon hopefully.

Share This Page