Resolved rMBP + OSX Mavericks + Dell U3011 over Displayport = No good.

Discussion in 'MacBook Pro' started by NutsNGum, Oct 6, 2013.

  1. NutsNGum, Oct 6, 2013
    Last edited: Oct 30, 2013

    NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #1
    Just to make anyone with the above combination aware, though I'm sure it applies for any monitor using displayport.

    Last night, upgraded my RMBP to Mavericks. Previously I'd been able to use my U3011 over Displayport using an EDID override file which forced the display to use RGB mode and get the MacBook to recognise the monitor as a computer display and not as a TV.

    Mavericks seems to break this, and my machine is now reporting the monitor as a television again. The colour and text is all fairly whacky-looking.

    I'm hoping someone smarter than me can provide a solution.
     
  2. Periastron macrumors newbie

    Joined:
    May 29, 2010
    Location:
    The Canadas
    #2
    I also had this issue initially after upgrading to 10.9, but it appears that the update merely wiped my custom display entry out of /System/Library/Displays/Overrides. After replacing the custom entry and rebooting, my external display went back to behaving like an RGB monitor again.
     
  3. thedarkhorse macrumors 6502a

    Joined:
    Sep 13, 2007
    Location:
    Canada
    #3
    I'll try my 2913wm after work through displayport but I never needed any override to get it to work properly before so I imagine it will be fine.
     
  4. swerve147 macrumors 6502a

    swerve147

    Joined:
    Jan 12, 2013
    #4
    Same monitor here, no problems at all, before or after Mavericks, on DisplayPort.
     
  5. thedarkhorse macrumors 6502a

    Joined:
    Sep 13, 2007
    Location:
    Canada
    #5
    Just testing mine now and it works the same as before mavericks, my custom calibration also carried over. For a second I thought it wasn't working at all but I had connected it to the DP out meant for daisy chaining :p
     
  6. klagermkii macrumors member

    Joined:
    Mar 15, 2007
    #6
    I'm using a Dell U2711 and it lost the EDID file when upgrading to Mavericks and reverted to YPbPr. Just went back to http://embdev.net/topic/284710 ran the patch-edid.rb file, and put the resulting display override file back in the right folder and it worked.
     
  7. NutsNGum thread starter macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #7
    Thanks all,

    It was still working technically without creating a display override file, but it was reporting the monitor as a television and had noticeably reduced font legibility. I've recreated the display override profile and now the colour etc. is fine. I've noticed though, when i go into display preferences, it is showing the television image where a monitor icon should be. Is anyone else getting this?

    I don't think it's affecting anything, it's just bloody irritating.

    I've attached the image.
     

    Attached Files:

  8. Periastron, Oct 30, 2013
    Last edited: Oct 30, 2013

    Periastron macrumors newbie

    Joined:
    May 29, 2010
    Location:
    The Canadas
    #8
    Yes, I get the same thing. So long as the monitor itself displays colours and text correctly, though, I think I can live with it. :)
     

Share This Page