rMBP - textbox and scroll lag is ridiculous with ML on Safari on battery

Discussion in 'MacBook Pro' started by 73CortinaV8, Aug 18, 2012.

  1. 73CortinaV8 macrumors 6502

    Sep 4, 2006
    Palo Alto, CA
    Every post I've read said the scroll lag has cleared up with Mountain Lion.

    My rMBP is fresh out of the box, so there shouldn't be junk temp files or caches kicking around.

    Textbox lag: For instance, typing in this message text box to submit this post is laggy. The letters shown are lagging what I have type by maybe a 1/2 to 1 second.

    Scroll lag: This page is very laggy:

    This is all on battery, with default power options. I have to say, I'm not very pleased after spending $3000.
  2. AZREOSpecialist macrumors 68000


    Mar 15, 2009
    No such issues here. I just went to the Redfin website and no lag whatsoever scrolling up and down. I'm running on battery power right now at 1680x1050 scaled resolution. As far as delays in typing text into text boxes, absolutely none whatsoever.

    I don't know what to tell you, but it sounds like something unique to your machine or setup.
  3. stevelam macrumors 65816

    Nov 4, 2010
    if its fresh out of the box i assume spotlight is currently indexing.

    even so, yes there is still definite lag on these machines.
  4. 73CortinaV8 thread starter macrumors 6502

    Sep 4, 2006
    Palo Alto, CA
    what about at the default display setting? I have exactly the same hardware as you. hmmmm
  5. 73CortinaV8 thread starter macrumors 6502

    Sep 4, 2006
    Palo Alto, CA
    it's just as laggy plugged in. I find it hard to believe there is something wrong with my hardware.

    Could it be some setting or something? I don't think the indexer is running - disk activity and cpu are zero.
  6. duffyanneal macrumors 6502a


    Feb 5, 2008
    Just tried it on it mine in Safari and Chrome with no problems. Sure the web page has a small amount of lag, but nothing earth shattering. No delay at all typing this.
  7. jbud72 macrumors member

    Mar 21, 2010
    Miami, FL
    Weird. My rMBP on ML scrolls perfectly, even on FB
  8. derbothaus macrumors 601


    Jul 17, 2010
    Did you try in all resolutions? Did you try forcing 650 instead of 4000? Did you try an external monitor? I have no lag on cMBP at 1440x900, 4000 or 650.
  9. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    The choppy scrolling is a widely known and much discussed issue right now.

    Hopefully, it's temporary until we get a software update from Apple.

    Although it doesn't cure the problem altogether, one thing that I've noticed that helps is turning off extensions and not using any style sheets in your settings.
  10. lulla01 macrumors 68020


    Jul 13, 2007
    Go to power settings and turn off auto graphics switching on battery.

Share This Page