Rock Band vs Rock Band Free: Different OS requirements. Why?

Discussion in 'iOS Apps' started by TheSpaz, Feb 3, 2010.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    Don't flame me because I'm running 2.2.1. Yes, I know it's old and I like it better than 3.x. Just getting that out of the way. Now onto the topic at hand.

    I was browsing the App Store on my iPhone the other night and I saw that Rock Band has a Free version, so I clicked "buy" and it started downloading. I was startled because I thought it was a 3.0-only app, but I guess not. Anyway, I really liked it and I decided that I wanted to buy the full version, but guess what... the full version needs 3.0 or higher to play it.

    Why the heck does the demo run fine on 2.2.1, but the full version needs 3.0? This was kinda disappointing, but I can't really be angry because I am the one who chooses to stay on 2.2.1. I just thought it was kind of weird that they'd make the demo backwards compatible while the full version requires 3.0.

    I wonder if they'll make the next update backwards compatible to 2.2.1. I realize some of the multiplayer features will not be there, but I don't care about that.

    Any thoughts on this? Should I email the Rock Band developers and ask them to make it backwards compatible or do you think they'll ignore me because I'm probably the only person left in the world who still prefers 2.2.1.

    Thank you.
     
  2. bozzykid macrumors 68020

    Joined:
    Aug 11, 2009
    #2
    The paid version has push notifications which will not work on 2.x. Thus the 3.x requirement.
     
  3. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #3
    Yes, it's true that push requires 3.0, but there are a number of apps that have push but still work on 2.2.1. The feature just isn't there if you're running 2.2.1. So that's not a valid argument. eBuddy for example has push notifications, but requires 2.0 or greater.
     
  4. bozzykid macrumors 68020

    Joined:
    Aug 11, 2009
    #4
    It is a valid argument. My guess is they used the 3.x SDK and have no plans to try to support both SDK versions. Can they get around the 3.x requirement? Of course. But they aren't required to and they can probably look at their analytics and see that it wouldn't be worth it to them.
     
  5. fishkorp macrumors 68020

    fishkorp

    Joined:
    Apr 10, 2006
    Location:
    Ellicott City, MD
    #5
    Paid Rock Band has a lot of 3.x-only stuff in it (push, in-app purchasing, etc). A one-off 3.x feature is easy to code around. When you start mixing a lot of them, it gets more complicated.
     
  6. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #6
    My point is... they shouldn't support 2.0 for the free version. They should keep them all the same compatibility.

    That's just weird. If I forgot to look at the requirements for the full version, I could have accidentally bought it thinking that it was compatible with my OS version.
     
  7. strike1555 macrumors 6502

    Joined:
    Jun 29, 2009
    #7
    Yeah it is pretty odd they do that but I wouldn't bother emailing them. We're talking about EA here, it's high unlikely they would give a flying f***.
     
  8. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #8
    The full Rock Band app is now 2.2 compatible now. Hmm. Weird. I might have to buy it. I love Rock Band!
     

Share This Page