S.O.S. Please!!! OS X 10.4.11 Disk Utility Not Able to Repair

Discussion in 'macOS' started by tncdel, Jan 20, 2009.

  1. tncdel macrumors newbie

    Joined:
    Jan 9, 2009
    #1
    I tried, unsuccessfully, using the computer's utilities program to repair the disk.

    I followed standard procedure, by booting up from the OS X 10.4 install disk, selecting UTILITIES, then DISK UTILITIES. Once the DISK UTILITY opened, I selected the OS X 10.4.11 disk. Then I clicked on the REPAIR DISK button, and let it go through the scan / repair cycle. But it stopped near the end, giving me this message:


    ______________________________________

    [in red letters]
    invalid node structure
    The volume Mac OS X could not be repaired after 3 attempts

    Error: The underlying task reported failure on exit

    [in black letters]
    1 HFS volume checked

    [in red letters]
    1 volume could not be repaired because of an error

    [in black letters]
    Repair attempted on 1 volume

    [in red letters]
    1 volume could not be repaired

    ______________________________________


    After I got that message, I shut down, then restarted manually after waiting about ten seconds, rebooting from the OS X 10.4.11 install disk as before. But when I got to the DISK UTILITY page again, this time I did the other of the three things [verifying permissions, etc.], before re-running the disk repair again. And again I got the same message as above.

    Other than that, my computer seems to be working okay, except for the iPhoto. If I edit one photo, it does nothing more. Not even quit. So I must force-quit to exit iPhoto, and re-open each time I want to edit a photo, unlike before I up-graded from OS X 10.2 to 10.4.11.


    Additionally, I tried, unsuccessfully, going into SINGLE USER MODE, by rebooting again, this time holding down both the C key and the S key. But the computer monitor stayed GRAY color, without switching to BLACK. So after holding down the C and the S keys for several minutes, and still no black page came up, then I gave up waiting for it and shut down the computer manually. And let it sit for about a minute, before rebooting a fourth time, and again trying the DISK UTILITY, and again getting the above message.

    So PLEASE tell me what I can do now. Is there anything I can do to repair the disk, short of saving all files then erasing the disk, and starting over?

    As you may have already perceived, I'm no expert. PLEASE HELP.

    Thanks in advance.


    -Tom



    P.S. How do I get to SINGLE USER MODE with the OS X 10.4.11?
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  3. tncdel thread starter macrumors newbie

    Joined:
    Jan 9, 2009
    #3
    I consulted with a tech guy at MacMall, and he said that the Disk Warrior program is good, but will not actually repair the disk. He said it has limited capabilities, although what it can do it does well.

    And I'm not eager to fork over $100 for something that may not correct the type of problem I'm having.

    By the way, do you know how I can get to the SINGLE USER MODE on my computer with OS X 10.4.11?
     
  4. tncdel thread starter macrumors newbie

    Joined:
    Jan 9, 2009
    #4
    Problem Solved

    Rather than spend $98 on Disk Warrior, not knowing if it would correct the problem, I simply replaced the hard drive altogether for $70. Replacing the 80G original with one 250G.
     
  5. lostngone macrumors demi-god

    lostngone

    Joined:
    Aug 11, 2003
    Location:
    Anchorage
    #5
    Does SMART say verified or failed?


    Do the Discs that come with the Mac have the hardware diagnostics or is that just on the Applecare cd?
     
  6. ehendel macrumors newbie

    Joined:
    Feb 17, 2009
    #6
    Back up your files!

    I don't know what the problem is, but back up your files now! Don't wait! If the disk dies (and it could die when you're not expecting it), you'll be glad you did.
     
  7. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #7
    Actually the OP said (2 posts before yours) that he just replaced the drive instead.;)
     

Share This Page