Safari & Apple Registration

Discussion in 'Mac Apps and Mac App Store' started by losfp, Mar 20, 2003.

  1. losfp macrumors regular

    Jul 16, 2002
    Am I the only one to find this one, or am I slow? :D

    Had my 12" PB for a couple weeks now.. and thought.. gee.. maybe it's time to register it with apple!!! so I loaded up and tried to register it. Didn't load up!! kept returning "safari can't load this page, yo" messages.

    That's odd, I thought. Ah well, my internet connection has been playing up all night anyway. No.. everything else seems to work just fine...

    After 10 frustrating minutes I loaded up MSIE and it worked!!!

    Note for the Safari developers.. uhh guys, how about making it work on the apple site? :) oddly, it's only one of a couple of secure sites that I have found that have issues with Safari.
  2. edesignuk Moderator emeritus


    Mar 25, 2002
    London, England
    It's not just u, I get it all the time. When I first try to access I normally get the error saying the page could not be found/loaded, but on a 2nd attempt it normally works. Very strange none the less. Should be sorted out though by the time of the final build.

    BTW, it works first time in Camino ;)
  3. Billicus macrumors 6502a


    Apr 3, 2002
    Charles City, Iowa
    Same here. But it hasn't always been this way. I can remember loading on the first try.:confused:

Share This Page