Safari, Firefox, Opera all taking up 130% of my cpu?

Discussion in 'macOS' started by impulse462, Jul 24, 2009.

  1. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #1
    Is there a reason that whenever I have more than 5 tabs open in any one of the aforementioned browsers, the browser starts to take anywhere between 90 and 130% of my cpu?

    I understand that flash is poorly optimized for os x, but this is getting ridiculous, my cpu temperature is hitting 61C just by having a 6-7 tabs open.

    Keep in mind that this happens only sometimes, but more often than not. At one point I had 15 tabs open and safari was only taking around 25% of my cpu.


    Anyone got any fixes?
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    Do any of those tabs contain Flash? If so, that's your problem.
     
  3. impulse462 thread starter Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #3
    Only one of them contained flash, and it wasn't a streaming video such as on youtube or etc. it was a flash ad. Is that was taking up all my cpu?

    ...thats pretty ridiculous
     
  4. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #4
    That was probably it, Flash sucks, and there is nothing that can be done about it until Adobe fixes the problem.
     
  5. Steve-M macrumors regular

    Joined:
    Jun 12, 2009
    #5
    I don't think flash is the problem. I can watch youtube video's and safari runs 40-50%
     

Share This Page