Safari is extremely slow and sluggish out of the blue

Discussion in 'OS X Yosemite (10.10)' started by MosesOlsen, Sep 11, 2014.

  1. MosesOlsen macrumors newbie

    Joined:
    Jul 10, 2012
    #1
    I was worried it was my computer, but it turns out it's just Safari. For example, on MacRumors when I click the Forums tab, it will take a few seconds to even register, then the loading wheel pops up for another few seconds. It's really annoying. Youtube videos are a pain to load. However, I've tested the same sites on Chrome and it's perfectly fine. I guess it's important to note that I just started having problems today. I prefer Safari and haven't had any problems in the past.

    I'm running the Yosemite public beta by the way. Any help would be appreciated. Thanks.
     
  2. ABC5S Suspended

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #2
    For me, I've had issues with lag getting on MacRumor site, but nothing else yesterday, and today it's all is well with both Safari, favorites and MacRumor forum. Go figure :confused:
     
  3. wolfpackfan macrumors 68000

    Joined:
    Jun 10, 2007
    Location:
    Cary, NC
    #3
    I am experiencing the same thing for some strange reason. Lots of spinning beach balls.
     
  4. jterp7 macrumors 6502a

    Joined:
    Oct 26, 2011
    #4
    haven't use chrome so much since this new update lol. Hope they fix it soon.
     
  5. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #5
    Check to see if there are any gifs on the page you're at. I've found these files can (but not always) send Safari through the roof in both memory usage and CPU.
     
  6. Vane, Sep 14, 2014
    Last edited: Sep 16, 2014

    Vane macrumors newbie

    Joined:
    Jul 10, 2013
    #6
    same issue here.

    _____

    The new update solved all of my Safari issues. Nicely done, Apple!
     
  7. MaxPayne79 macrumors regular

    Joined:
    Jun 11, 2014
    #7
    Reset you PRAM and more importantly your SMC settings. That clears a bunch of stored ***** form all the various DP and beta updates. And reset whatever else you can on your mac to clear up the Roms. After i reset the SMC in particular, safari not only sped up noticeably but I haven't encountered any lag yet, thank god. :)

    ----------

    Rest your PRAM and SCM settings.
     
  8. Traverse macrumors 603

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #8
    I have found that the new Safari randomly stops working correctly. I'll start browsing and it's lightening fast and smooth and will suddenly become extremely laggy. It's buggy, but I'm sure that the GM will improve it.
     

Share This Page