Safari no longer working with Bank of America

Discussion in 'Mac Apps and Mac App Store' started by danny_w, May 12, 2011.

  1. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #1
    Starting a few days ago Safari 5.0.4 quit being able to login to Bank of America. It gets to where it would normally load the Accounts page and says that it cannot create a secure connection, but Firefox works fine and does not indicate a security issue. Besides which Safari randomly takes a different login approach; instead of going straight from the initial login page to the Sitekey page it goes a circuitous route where I have to enter the state and account name (again) before going to the Sitekey page; I have never seen this problem using Firefox. It would appear that something in Safari is not fully compatible with Bank of America, one of the largest banks in the world. Has anybody else seen these issues?
     
  2. colourfastt macrumors 6502a

    colourfastt

    Joined:
    Apr 7, 2009
    #2
    No problem with BoA here.
     
  3. dionnfr macrumors member

    Joined:
    Dec 18, 2009
    Location:
    Lewiston, New York
  4. TonyK macrumors 6502a

    TonyK

    Joined:
    May 24, 2009
    #4
    Running 5.0.3 and logged in just fine. Have not gotten the .0.4 build yet.
     
  5. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #5
    I just signed into BofA without any problems.
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    BoA site works for me too. Clear you cache or cookies, or both.
     
  7. rupertmayo macrumors newbie

    Joined:
    Jul 22, 2011
    #7
    I have had the same problem for years, and can't figure out why?? i have to use firefox. with each safari update i think the problem will go away, but it doesn't
     

Share This Page