Safari Web Notifications, not working with latest Safari?

allan.nyholm

macrumors 65816
Original poster
Nov 22, 2007
1,129
346
Aalborg, Denmark
Hi,

I was sitting here wondering how come MacRumors doesn't serve me notifications to news stories.

Despite having Safari allowing for websites to serve me notifications there simple aren't any. Not from anywhere because no website serves me any.

Is this a common problem for any one of you Safari users like myself? Any solutions at hand?

I read that in the latest Safari release notes it's described as the Web Notifications requires a user interaction. What is this particular user interaction? I'm tired in my arm from waving and quite frankly tired of staring into my webcam whilst blinking.

macOS Mojave 10.14.4 and Safari Version 12.1 (14607.1.40.1.4)
 

allan.nyholm

macrumors 65816
Original poster
Nov 22, 2007
1,129
346
Aalborg, Denmark
Maybe you need to re-subscribe to notifications for Safari to accept them (on the site, so e.g. go to Resubscribe Now)?
Tried that to no end, and also just now because I thought it really was the solution and that I was about to feel very stupid. The list of websites in Safari preferences remains empty. I recently reinstalled macOS Mojave from a 10.14.3 USB and updated to current macOS Mojave. Nothing else is changed. SIP is off though - the issue was there before turning SIP off.
 

macarthurdent

macrumors newbie
Mar 28, 2019
12
0
I had the same issue and this is what fixed it for me:
Go to System Preferences > Privacy > Enable Location Services. Tick the Safari checkbox.
Restart Safari.
Go to Safari Preferences > Notifications. Select 'Allow' in the drop-down menu for Macrumours.
Restart Safari.
Resubscribe to Push Notifications.
MacOS Mojave 10.14.1 on my 2015 15" MacBook Pro
 
Last edited:

allan.nyholm

macrumors 65816
Original poster
Nov 22, 2007
1,129
346
Aalborg, Denmark
I had the same issue and this is what fixed it for me:
Go to System Preferences > Privacy > Enable Location Services. Tick the Safari checkbox.
Restart Safari.
Go to Safari Preferences > Notifications. Select 'Allow' in the drop-down menu for Macrumours.
Restart Safari.
Resubscribe to Push Notifications.
MacOS Mojave 10.14.1 on my 2015 15" MacBook Pro
Thank you for the help - I have unsuccessfully been able to let Safari show me notifications for websites despite all this. Safari doesn't appear in the location you describe in System Preferences on my Mac with macOS Mojave 10.14.4.
I'll investigate some more.
 

allan.nyholm

macrumors 65816
Original poster
Nov 22, 2007
1,129
346
Aalborg, Denmark
@JennaDee123 I have a thought that goes something along the lines that Apple has changed the method within Safari for allowing notifications and some websites hasn't kept up(including this one)
AppleInsider is another website that I know was giving me an option to show some news stories in Notification Center. Perhaps I ought to ask in the MacRumors Site Suggestions thread about this.
 

allan.nyholm

macrumors 65816
Original poster
Nov 22, 2007
1,129
346
Aalborg, Denmark
And as of right now, night time where I live, MacRumors' Front Page displays a notice about needing permission to allow notifications and after following the link = success.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.