Safari won't work anymore, says I don't have 10.5.2

Discussion in 'Mac Apps and Mac App Store' started by Braby, Nov 10, 2008.

  1. Braby macrumors member

    Joined:
    May 9, 2007
    #1
    I tried to open Safari the other day and it failed to open, so I un-installed it and downloaded a new one from Apples website. When installing it says I do not have 10.5.2, but really I have 10.5.5.

    Any idea why it won't install for me? I'm using Firefox right now and I really don't like it.

    Thanks a lot.
     
  2. Braby thread starter macrumors member

    Joined:
    May 9, 2007
    #2
    I think maybe it goes deeper than that.

    Last night everything was freezing so I rebooted and instead of the Apple logo, a folder logo came up. It wouldn't boot up, so I tried to reformat today and the HDD wouldn't show up. I took it in earlier this year and they said it was an OS problem, but now it is happening again. Is it possible to be the Leopard disc or maybe it is a damaged HDD?. I'm thinking of backing up my media and repairing the HDD and formating it.
     

Share This Page