Samsung 840 evo in drive bay not booting on Macbook pro early 2011 with Yosemite

Discussion in 'MacBook Pro' started by tterraz, Mar 1, 2015.

  1. tterraz macrumors newbie

    Joined:
    Mar 1, 2015
    #1
    Hi there,

    It's almost all in my title, but here is a bit more explanations.

    I bought a new Samsung 840 evo drive (500G) and an adaptor to put it in my drive bay. I now have my original 500G HD and the 500G SSD.

    I successfully installed Yosemite on my SSD, but when I restart, I have "the" sign (round with a bar), and my computer boots on the HDD.

    I restared a few time in debug mode and reselected the SSD as a startup disc, but it always does the same thing. My first try was by cloning my HDD to my SDD, then I did a clean install from a memory stick, still the same result.

    I am reading a lot of things about Yosemite and SSD's, but since I never used a program to enable TRIM I should be be concerned right?

    My next move might be to swap my HDD and my SSD, but I would like some advice first and know if that will help in any way... My MBP is an early 2011 one.

    Thanks for your help!
     
  2. donlab macrumors 6502

    donlab

    Joined:
    Jun 3, 2004
    Location:
    USA
    #2
    make sure ribbon cable connections between drive and mother board are secure and try again.

    Don't worry about trim. once you get everything working, shrink your primary partition by 50GB using disk utility. That will leave 50GB for the drive's house cleaning.
     
  3. glenthompson macrumors 68000

    glenthompson

    Joined:
    Apr 27, 2011
    Location:
    Virginia
    #3
    By drive bay, do you mean the optical bay? If so there is a problem with that vintage MBP not supporting full SATA III in that bay. Move the SSD to the main drive bay and give it a try.
     
  4. tterraz thread starter macrumors newbie

    Joined:
    Mar 1, 2015
    #4
    Problem solved

    Hi guys,

    Switching my 2 hard drives made the trick.
    I now have my SSD in the "primary bay", and my old HDD in the "DVD bay"

    Thanks for your kind help!
     

Share This Page