Samsung Magician (Windows) Made My Mac OS X Partition Non-Bootable. Data Still Exists

Discussion in 'iMac' started by Dailafing, Oct 4, 2014.

  1. Dailafing macrumors newbie

    Joined:
    Sep 23, 2014
    #1
    Problem:
    When holding down alt on boot, I can only see my windows partition, and I can only boot to Windows 8.1.

    Process To Get To Problem:
    Brand new Samsung 840 Pro SSD installed,
    Made USB Installer for Mavericks,
    After installing, I immediately ran bootcamp at 50/50 partition, with win 8.1 installer on a USB flash drive ready.
    Once both were installed, I primarily used windows 8.1, and ran Samsung Magician with the aim to test and improve performance.
    I enabled Rapid mode, and over provisioning.
    And now I cannot boot to Mac OS X.

    I've tried:
    • Disabling Rapid mode, and over provisioning.
    • Running Disk Utility from USB Installer. Couldn't run 'Repair Disk', it gave some error message about backing up my data asap, and then formatting the drive.
    • Reinstalling Mac OS X. But upon clicking install, just after verifying with Apple, it tells me to contact AppleCare.

    I'm currently typing this on a USB boot of the drive I removed from my iMac, and can see in Disk Utility that the drive is visible, and appears to have 3 partitions that are all dismounted, and read out as "disk0s2", "disk0s3" and "disk0s4"... these are greyed out texts under the hardware name of the drive: "512.11 GB Samsung SSD PRO Series Media"

    If I select the drive (not the partitions) and click "Repair Disk", the log box populates, and a pop up says,
    The log then reads as:
    If I select "disk0s2", and press 'Repair Disk', the log box populates, and a pop up says,
    The log then reads:
    The same happens for the other partitions, except "disk0s4"'s log appears as:
    The messages otherwise appear the same...

    I'm really stuck, and hoping for some expert advice.

    I'm familiar with terminal commands, and very confidant with making alterations. I'm sure theres some terminal command I could enter to fix all this, right?
     
  2. Dreadnought macrumors 68020

    Dreadnought

    Joined:
    Jul 22, 2002
    Location:
    Almere, The Netherlands
    #2
    Can you startup in recovery mode? Hold down :apple: and R at startup. If this is possible, run disk utility and you should be able to repair your hard drive. Good luck!
     
  3. Dailafing thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #3

    Nope, I have sinced tried resetting PRAM, holding shift for safe mode, cmd+R, cmd+s.... It ignores everything, and boots to windows. PRAM reset is working, as in... It's restarting with a 2nd chime. But it does t help.

    But just to be clear, disk utility is NOT helping. I got to disk utility from a USB boot, and I've been rather clear on the responses disk utility has given me. So I don't see how your answer applies here?

    Regards
     
  4. jwhazel macrumors regular

    Joined:
    Sep 22, 2005
    #4
    HFS+ is a very touchy filesystem. I have no real hard evidence to back this up but I suspect that over provisioning may have done something to the partition map.

    Data is valuable: when I worked in mac repair, Tech Tool Pro was able to repair maybe 50% of the things disk utility couldn't when it came to weird partition corruption. Barring that, dd should be available from within a bootable partitions terminal. You can use that to bitclone the entire drive to something else in attempt to recover data and then do a wipe and re-install on the samsung.

    Data is not valuable: save yourself some time and headache and stop messing with it and just wipe and re-install.
     
  5. FreemanW macrumors 6502

    Joined:
    Sep 10, 2012
    Location:
    The Real Northern California
    #5
    Excellent post.

    Thank you for good information.
     

Share This Page