SBSettings crashes jailbreak with 4.3.2. Crash reporter says "lockinfo" is issue

Discussion in 'Jailbreaks and iOS Hacks' started by wwooden, Apr 25, 2011.

  1. wwooden macrumors 68000

    wwooden

    Joined:
    Jul 26, 2004
    Location:
    Burlington, VT
    #1
    My iPhone 4 was on iOS 4.1 for months with an untethered jailbreak. I had my phone setup exactly as I wanted it to include LockInfo and SBSettings, as long with many other tweaks.

    Well, I dropped my phone last Thursday and it shattered the front screen. I had to unjailbreak to take it to Apple to get a replacement. The new one had 4.3.2 and I went about reinstalling all my jailbreak apps.

    Everything works find except when I go to install SBSettings. It will crash my phone and go into safe mode each time. Only way to get back to the working jailbreak is to remove the SBSetting install through Cydia.

    Crash Reporter says the issue is "lockinfo" and the "mail plugin". I've tried disabling the mail plug-in and reconfiguring it but nothing seems to let SBSetting install. Lockinfo is much more important for me to have then SBS so I don't want to remove it.

    Here is the list of jailbreak apps I have installed:

    Activator
    Better Lockinfo Icons
    BiteSMS
    biteSMS NoPink Retina
    CameraButtons
    Clock Plugin for Lockinfo
    crash reporter
    Cyntact
    FakeClockUp
    Fast Copy
    Five Icon Dock
    Five Icon Switcher
    FolderCloser
    Lockinfo
    Mario SMS Tones
    No Page dots
    NoSpot
    Popup Blocker
    TetherMe
    Twitter Plugin for lockinfo
    VibraficationsFree
    Weather Plugin for lockinfo
    Wi-Fi sync
    Winterboard

    I had this exact setup with 4.1 and no issues with SBSetting.

    Anyone have an idea of or if anything is calling the issue? I'm at a loss. Maybe something changed (obviously) from 4.1 to 4.3.2 that I'm not aware of.

    Thanks.
     
  2. Cortezbanks macrumors 6502

    Joined:
    Sep 5, 2008
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    Weird. I'm on 4.3.2 with both lockinfo and sbsettings and no problems here
     
  3. 3gsiFone macrumors newbie

    Joined:
    Apr 25, 2011
    #3
    I have the same crashing problem + freezes every time I press volume keys, during call. I used snowbreeze 2.6 to jailbreak.
     
  4. musicmax macrumors member

    Joined:
    Aug 11, 2009
    #4
    I had a similar problem with the 4.3.1 jb and a different LockInfo plugin (Appigo ToDo). A few remove/reboot/reinstall cycles set me right.
     
  5. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #5
    same issue here on iPhone 4 4.3.1

    it has a mail and sms plugin issue

    I think I found out the problem, disable the homescreen lockinfo, and everything should be fine
     
  6. jeffmlr macrumors newbie

    Joined:
    Apr 28, 2011
    #6
    I'm experiencing the same issue with nothing but SBSettings installed on an iPhone 4 w/ 4.3.2 (after a fresh jailbreak w/ Cydia). Has anyone had any luck finding a resolution?
     
  7. wwooden thread starter macrumors 68000

    wwooden

    Joined:
    Jul 26, 2004
    Location:
    Burlington, VT
    #7
    I pretty much did the same thing. I started removing all my jailbreaks until all that was left was SBSettings and it still crashed.

    I haven't come to any solutions yet.
     
  8. whiskeyvol macrumors regular

    Joined:
    Mar 14, 2011
    #8
    same here
     
  9. dudeabiding macrumors 6502

    dudeabiding

    Joined:
    Aug 24, 2009
    #9
    SBSettings is still ok with my 4.3.2, but I've removed Lockinfo for now. I had some SafeBoot issues with 4.3.1, and after I did the upgrade, and was reinstalling, I went to install the Weather plugin and it crashed me. I removed all Lockinfo stuff and no crashes since. I'll try it again after the next Lockinfo upgrade, or when I feel I have the time to mess with it. For now, not a single crash in three days.
     
  10. bmwhd macrumors 6502a

    bmwhd

    Joined:
    May 22, 2008
    #10
    I'm running a huge mass of SBSettings plugins and Lockinfo tweaks on 4.3.2 with no issues. 50 packages in all.
     
  11. natedizzles macrumors newbie

    natedizzles

    Joined:
    Dec 20, 2010
    Location:
    California
    #11
    It's the combination of biteSMS and lockinfo. I restored my iPhone, and install just those two apps. Crashes everytime you have biteSMS running in the background (multi-tasking). If it's running in the background, and you get off a phone call, a repeated text will pop up, and when you press the X button it will crash. But, when you press the home button, and go into SBSettings and remove all running apps in the background, it won't crash.

    I've been doing that for awhile, but I think one day I know I will get so annoyed I'm just going to stop using one or the other.
     
  12. IAmMicki macrumors newbie

    Joined:
    May 17, 2011
    #12
    me too!

    This is exactly my issue, step by step. Hoping that LockInfo comes out with an update very soon.
     
  13. Riptide62 macrumors member

    Joined:
    Jun 25, 2010
    #13
    On 4.3.3 on a 3GS and had similar issues (and more) resolved my own problems by deleting Cydget.

    Also, in SBSettings, go to >more>Mobile Substrate Add-ons and toggle on/off apps one by one until you find culprit.

    I had also installed Xsellize as a source and for me that presented nothing but problems. I eliminated it as a source (using iFile) and any associated apps, reinstalled those key apps I wanted (Lockinfo, SBSettings, BiteSMS) and I have had zero problems since.
     
  14. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #14
    One more person here running latest lockinfo and SBSettings with no issues whatsoever. iP4, 4.3.3, jailbroken with Redsn0w
     
  15. dashrendar macrumors member

    Joined:
    Aug 29, 2010
    #15
    4.3.2 with LockInfo, BiteSMS. and SBSettings. no problems whatsoever.
     
  16. bmwhd macrumors 6502a

    bmwhd

    Joined:
    May 22, 2008
    #16
    I will amend my earlier post - I've upgraded to 4.3.3 and added a couple of additional tweaks to my iP4. My current config has a combination of two different winterboard themes (Smoog visuals and EPHD sounds) plus HTC Weather Widget 1.7 and Live Clock.

    Every 3rd or 4th reboot of the phone ends up in Safe Mode on the springboard. Not sure why but I think it's related to this issue as I also get Safe Mode every once in a great while from LockInfo as well. Usually if I get a simultaneous iRealSMS popup on top of a Calendar popup.
     

Share This Page