Seriously freaking out...I get the console for a login screen...

Discussion in 'Mac Apps and Mac App Store' started by King Cobra, Feb 15, 2004.

  1. King Cobra macrumors 603

    Mar 2, 2002
    I get the console for a login screen and can't get the Finder GUI after the boot panel!

    -->Cube 500MHz w/10.3.2, ample memory/HD space

    What started it:
    I deleted nearly every enhancement related to ShapeShifter, then tried to log out. The logging out process never finished. So I force a shut-down. I do a "fsck" ... no problems. So I reboot, get to the logging in part...but I'm greeted with a console message, something like:

    "Darwin/BSD ([my computer].local) (console)

    Username: "

    white text on black background.

    I tried doing additional fsck's, all positive. I've tried resetting the open firmware, zapping the PRAM multiple times, repairing the disk from the CD, repairing permissions from the CD, even installing the 10.3.2 Combo Update (again) from my 466MHz iBook, which I'm on now. And even AFTER all that, I STILL get the console thing.


    How do I get out of the damn console?
  2. titaniumducky macrumors 6502a


    Nov 22, 2003
    Try doing a clean install of OS X. I don't trust haxies.
  3. janey macrumors 603


    Dec 20, 2002
    sunny los angeles
    dont use haxies lol.
    anyway, do you have auto login enabled?
    maybe that might be your prob. but if i were you i'd start over, reinstall the OS.

    I love that thing, you login as ">console" or whatever it is, and it does that...freaks n00bs out :p
  4. King Cobra thread starter macrumors 603

    Mar 2, 2002
    Well for about the third time today Carbon Copy Cloner continues to save my ass...I copied my "working" OS X folders over from my iBook to my Cube, and it works.

    I have manual logging in.

    And the problem occurs when I replace the Extras.rsrc file (in /System/Library/Frameworks/Carbon.framework/Frameworks/HIToolbox.framework/Resources/) with another file of the same name. I'm used to this procedure for "hacking" the Jaguar theme, but it doesn't work (cleanly) in Panther. :rolleyes: :mad:

    BTW: A haxie program was NOT the cause of the problem. "It" was my manual swapping of the Extras.rsrc files from root user. :eek: :eek: :eek:
  5. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    I'm not 100% consistent on this, but I've found (through hard experience) that it's worth making a backup of system files before manually editing them. ;-) I was mucking around with a system preferences file a few months ago, and managed to destroy my ability to launch aqua. Fortunately I'd copied the file to a "-backup" version ahead of time, so restoring it was pretty simple.

    Understanding what some of these files do is made a bit more complicated, since it appears Apple is transitioning over to a more Unix-like organizational structure (a good thing, IMO). I ran across a system file (forget which one) where the comments said something like "don't count on this being here in future versions of the os; this is just a stopgap". :)

Share This Page