Severe Scroll lag on Safari 5.1 in OSX 10.6.8

Discussion in 'macOS' started by puma1552, Aug 19, 2011.

  1. puma1552 macrumors 601

    Joined:
    Nov 20, 2008
    #1
    It's almost unusable, and has been for a while. Scrolling is terribly laggy and choppy, on every website, even this one. I can't recall if it started right when I installed 5.1, after, or before.

    Resetting PRAM/SMC did nothing, and activity monitor shows nothing out of the ordinary (sub 1% CPU usage).

    Ideas? I've really had it with this.
     
  2. PS65 macrumors 6502

    Joined:
    Jan 25, 2008
    Location:
    United Kingdom
    #2
    What does Activity Monitor show for Real Memory?

    If you use iStat, how much free RAM is available?

    Check your Console, any errors?

    Repair Disk permissions?

    To be honest, it sounds like the Safari 5.1 memory leak issue, but run those checks in the first instance and let us know.
     
  3. tpg macrumors regular

    Joined:
    Mar 19, 2010
    #3
    I've just upgraded to Lion yesterday, although I was having similar issues with scrolling being a bit laggy in 10.6.8. If anything it's worse in Lion.

    Do you have developer tools installed? Curiously, if I fire up Quartz Debug, and check "Disable 2D Acceleration" under "Hardware acceleration", the scrolling performance seems greatly improved. This isn't a fix in that this disables hardware acceleration across the whole UI, but it suggests that it boils down to some kind of graphics issue...

    What hardware are you on btw? I'm on a late 2007 macbook (intel x3100 graphics) in case it's relevant.
     
  4. puma1552 thread starter macrumors 601

    Joined:
    Nov 20, 2008
    #4
    Thanks, everything looked good on my machine, MBP 6,2 (late 2010 2.66 Arrandale i7).

    I got fed up with it, so I downgraded to 5.0.5 and all is well until Apple figures out how to fix 5.1.
     

Share This Page