Shared photo invitations not working on the receiving end

Discussion in 'macOS Mojave (10.14)' started by donawalt, Dec 6, 2018 at 5:41 AM.

  1. donawalt macrumors regular

    donawalt

    Joined:
    Sep 10, 2015
    #1
    I know this is a long shot, as there is information I don't yet know, so I am looking for some advice for how to proceed in my investigation and/or how you would attack this problem - unless of course you have knowledge of this exact problem.

    The issue is, my daughter is no longer is able to view shared photo albums I invite her to. This all started when she got married and went through changing her name on stuff - which for this case means new email address but no changes to Apple ID. The background:

    1. I am on iCloud Photo Library. I think she is too.
    2. For years I would invite her to share photo albums along with other people. Its always worked. It appears when I invite her, it uses her contact on my devices.
    3. We are both all Apple - both have Mac, iPhone, iPad.
    4. She says that invites from other friends work fine. I have not verified that but she is pretty tech savvy.
    5. Her Apple ID is her OLD email address still. She has things set up so that any emails sent to her old/pre-married email address come to her new email address.
    6. What she has seen as we have tried to fix this, is sometimes no invitation appears at all; sometimes she sees it and accepts, and gets a spinning wheel but no photos (and the invitation does not show as accepted on my end). I think she has seen that she can accept but the album is empty. I am not sure I have ever seen a status of "Accepted" on my end, but I could be wrong on that.
    7. I have invited her by explicitly typing her phone number and her email address (new married one) in. I have also created a separate unique contact with just her pre-married email address (which happens to be her Apple ID), which does not show up in any other contacts now, and invited that person. She got the invite in email, but she just gets a spinning wheel.
    8. At one time I had her contact with both old and new email address. I then changed her contact to just have new email address.

    That's all I can think of, any ideas? How would you proceed? Thanks!
     
  2. donawalt thread starter macrumors regular

    donawalt

    Joined:
    Sep 10, 2015
  3. donawalt thread starter macrumors regular

    donawalt

    Joined:
    Sep 10, 2015
    #3
    OK it appears I have figured it out - both my daughter and I had turned off using mobile data for photos. I think we did it the summer, likely when her access to my shared albums stopped. We both turned it on, and shared albums are working fine now! So why in the world would that be? I turned off mobile use for photos so its not uploading 50 photos to iCloud on my cell plan, it just uploads them when I get to a WiFi network - that works great. But shared albums requires mobile Photo use...? Why wouldn't things work fine once the person got to a WiFi network? Weird. At least it's working now, albeit at the cost of cell plan data usage.
     

Share This Page