Shazam on iphone 3g?

Discussion in 'iPhone' started by Python49, Jul 26, 2012.

  1. Python49 macrumors newbie

    Joined:
    Dec 11, 2011
    #1
    Tried to search to no avail... I previously owned a jailbroken and unlocked first generation iphone i got off ebay that I use in a third world country. On this phone I was able to get shazam by simply searching in app store then installing.

    I now bought an iphone 3g that appears to be jailbroken (cydia installed) but when I try to install shazam it says i need iOS 4.3 or better. how is it possible a first generation was able to get shazam but not iphone 3g? Anyone know how I can install shazam on the iphone 3g?
     
  2. Python49 thread starter macrumors newbie

    Joined:
    Dec 11, 2011
    #2
    also wanted to point out that the previous first gen iphone i was using had shazam installed rather recently... within the past month, so why would I be able to still install from itunes app store on a first gen but not second gen?
     
  3. viperGTS macrumors 65816

    Joined:
    Nov 15, 2010
    #3
    The app on the iPhone 3G might have been a newer version that requires 4.3. Install the same exact version you installed on your iPhone 2G.
     
  4. Python49 thread starter macrumors newbie

    Joined:
    Dec 11, 2011
    #4
    all i did on the iphone 2g though was install the free one out of the app store... but when I go to the app store on the iphone 3g and install the free one it gives me that error.
     
  5. dccorona macrumors 68020

    dccorona

    Joined:
    Jun 12, 2008
    #5
    if you have it on iTunes still, you should be able to install from iTunes. The version on the store likely relies on some APIs that aren't available in older versions of the OS
     

Share This Page