iPhone Should I upgrade from 5.0.1 to 6.0.1 on my 4S?

Discussion in 'Jailbreaks and iOS Hacks' started by Lend27, Jan 20, 2013.

  1. Lend27 macrumors member

    Joined:
    Feb 26, 2004
    #1
    I love my jail broken 4s and hate to part with the JB.
    But there are now several iOs apps that I can't upgrade due to me being at only 5.0.1.
    Also, I don't want Apple to upgrade beyond the ios6 jailbreak they are working on, and be stuck at 5.0.1 until they jailbreak the latest apple version.
    Should I upgrade my 4s now to 6.0.1 just to be safe? I would lose my JB temporarily but hopefully would be able to JB again soon.

    Opinions?

    Thanks
    Len
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    I would wait till the next JB is relesed and then upgrade and jailbreak it again.
    Or if you dont care and want to be on stock firmware go to the latest 6.0.1
     
  3. Lend27 thread starter macrumors member

    Joined:
    Feb 26, 2004
    #3
    But what if Apple releases 6.1.0 and the jailbreak only covers 6.0.2?
    I'll then be caught in the middle won't I?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    They usually make it available for the latest firmware out but we won't know for sure till they give us more info.
    Keep your ears open and you should be fine.
     
  5. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #5
    Well, when they release it it'll be for the latest iOS version - So if 6.1 is the current version at the time of the JB release, I doubt they'll release one for an earlier version of iOS6. It happened with iOS5: 5.1.1 is the latest version of iOS5, and the current JB is for 5.1.1, so it'll happen with iOS6 as well :)
     

Share This Page