Sierra update “MacOS could not be installed on your computer; The installer resources have expired”

Discussion in 'macOS Sierra (10.12)' started by Jonboighini, Jun 10, 2018.

  1. Jonboighini macrumors newbie

    Joined:
    Jun 9, 2018
    Location:
    TN
    #1
    I’m running a late 2012 13” MacBook Pro 2.9gHz 8gb RAM 750gb hdd (from the best of my memory, I can’t access my specs at the moment)

    SO my MacBook has been having a problem starting up for a while now, however I can start up in single user mode and it works fine.

    Without considering my problem, I updated my MacBook from el captain to Sierra. I get the message “MacOS could not be installed on your computer” “the installer resources have expired”

    I’ve tried to return back to el captain by trying to through my startup disk, selecting the system “Macintosh HD OS X 10.11.6” but once I restart it just goes back to the installer.

    I’ve started up in recovery mode and tried to reinstall el captain but I get “an error occurred while preparing the installation”

    Also tried disk Utility and did first aid on my hd but no luck.

    I’ve attempted to run single user mode now and when I try mounting I get a message saying the device is write locked.

    I’ve tried internet recovery mode and safe mode but no luck either.

    I’m practically out of options now, please someone help! My next thought is to erase the HD and I’d really prefer not to.
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    Is the system date set correctly? I've never seen that message but it sounds like an encryption certificate may have expired.

    If it IS set correctly then try setting it back a year so that it's within the Sierra timeframe and see whether that makes any difference.
     
  3. Jonboighini thread starter macrumors newbie

    Joined:
    Jun 9, 2018
    Location:
    TN
    #3
    Thanks for the response! I checked the date and it was correct. Tried as you said and set the date back a year but I still get the same errors. Any other idea?
     
  4. TimothyR734 macrumors 6502a

    TimothyR734

    Joined:
    Apr 10, 2018
    Location:
    Logsden Oregon
    #4
    it could be your hard drive might be failing try with a differ hard drive
     

Share This Page