Significantly worse battery life with watchOS 2.2.2 for me. Anyone else?

Discussion in 'Apple Watch' started by vertsix, Jul 19, 2016.

  1. vertsix macrumors 65816

    vertsix

    Joined:
    Aug 12, 2015
    #1
    I finished the update a few hours ago and I noticed that the discharge rate is much more significant since the update, both while using and on standby.

    I don't usually complain about battery life unless it's truly an issue. I wanna see if anyone else has this issue, so I can determine if I should wipe it and restore from backup.

    Thanks for any useful feedback!
     
  2. Lodesman macrumors regular

    Lodesman

    Joined:
    Feb 4, 2014
    Location:
    Folkestone, Kent, UK
    #2
    No difference at all regarding battery life after update (mind you, it is only one day).

    Usually get two days use with about 20% remaining at the end of it. That said, I normally charge it every night (unless I go away and forget the charger).
     
  3. zhenya macrumors 603

    zhenya

    Joined:
    Jan 6, 2005
    #3
    Seems about the same so far here. I usually charge every day at lunch with 20-30% left and right now this morning I have 46% after updating yesterday at lunch.
     
  4. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #4
    Only two hours off the charger, but still at 100%.
     
  5. silvetti macrumors 6502a

    silvetti

    Joined:
    Nov 24, 2011
    Location:
    Poland
    #5
    Seems about the same for me...
    Usage: 1hour,29 minutes
    Standby: 5hours, 23 minutes
    Battery: 81%
     
  6. vertsix thread starter macrumors 65816

    vertsix

    Joined:
    Aug 12, 2015
    #6
    Alright, I'll restore my Apple Watch and see if it's better.

    Thanks!
     
  7. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #7
    We frequently hear from members complaining about the battery tanking after every single update, but most of them usually resolve after a few days or after unpairing/re-pairing.
     
  8. vertsix thread starter macrumors 65816

    vertsix

    Joined:
    Aug 12, 2015
    #8
    It seems the re-pairing fixed it.

    Strange.
     

Share This Page