SIM Failure after IOS7 (iPhone 4s/ATT)

Discussion in 'iPhone' started by schataut, Oct 28, 2013.

  1. schataut, Oct 28, 2013
    Last edited: Oct 28, 2013

    schataut macrumors member

    Joined:
    Jan 13, 2010
    #1
    Hi,

    After upgrading to IOS 7 (now 7.0.3) I get random "SIM Failure" on my phone (4s). What I have noticed is that it usually happens when I am using navigation. The only way to recover is to do a 2 button reset multiple times (sometimes I need to reset as many as 5 times to get it working again).

    I have done:

    1. Got a new SIM
    2. Reset network settings
    3. Restore the phone using iTunes

    However nothing fixed the issue. I am contacting apple about this problem because before IOS 7 I never had this issues. Please let me know if anyone is experiencing the same. Thanks.

    *********** Moving the question to IOS 7 thread **************
     
  2. HydroDog macrumors newbie

    Joined:
    Mar 17, 2013
    Location:
    Mossyrock, WA.
    #2
    I had the same problem on my 4s with Verizon as my carrier. Pissed me off to say the least! And IOS 7 SUCKS on the 4s. I spent 2-1/2 hours talking with Apple customer support about this and tried many different downloads. I had to get a new phone through Verizon and they told me luckily I bought the extended warranty.
    Which is BS because Apple said they would make it right which is BS also because I went with 4 days with NO cell service because of no phone and Apple sad they would credit me in my tunes account for my loss within 24 hours which they did not!
    Your Phone is DEAD.
    I got my new phone today from Verizon which is still a 4s but with IOS 6.
    I got home too late to call Apple but I'm looking at how sync my iTunes without having to go with IOS 7 because I have this feeling it will be crap again.
     

Share This Page