SimCity 3000 problems!

Discussion in 'Games' started by steadyeddie, Jan 8, 2004.

  1. steadyeddie macrumors member

    Oct 24, 2003
    OK, I know it's an old game now, but I've been trying to get SimCIty 3000 (which was bundled with my iMac a couple of years ago) running. I know it doesn't work on OS X, but I can't get it to work on OS 9.2.2 either! It's odd, because it worked fine when I first tried it a couple of years ago (probably under 9.2.0). Now the game starts up, gets to the main menu and then hangs when you click on any of the options to start a game. And yes, I have got virtual memory enabled (768MB of it!).

    Has anyone had a similar problem and managed to get round it? I really want to give this game a go!

  2. Daveman Deluxe macrumors 68000

    Daveman Deluxe

    Jun 17, 2003
    Corvallis, Oregon
    If you're trying to run the game in Classic, you shouldn't be. Boot into OS9.

    I'm running 9.2.2 and have had no problems.
  3. steadyeddie thread starter macrumors member

    Oct 24, 2003
    I'm booting right into 9.2.2, but no joy. I've also tried turning off all but the base extensions, but still no joy. I have a pretty clean 9.2.2 partition.

    I'm wondering if it's maybe because I have the game CD in an external firewire drive (my internal drive's knackered).

Share This Page