Siri hasn’t updated contact for wife, any suggestions?

gc15

macrumors regular
Original poster
Oct 23, 2012
177
1
Before I got married, my wife’s name in my phone was just her first name and then two emojis. Now after I changed her name in my phone, when I ask Siri to txt my wife or her name, she will always put the original emojis in the text message or when I ask to call her, Siri just responds to, do you mean “this name plus the emojis”.

Is this any way to fix this?

I’m assuming this is an iCloud issue, but I can’t seem to figure out how to fix it. On the iCloud website her contact info is the same as my phone.
 

fisherking

macrumors 604
Jul 16, 2010
6,764
1,710
ny somewhere
Before I got married, my wife’s name in my phone was just her first name and then two emojis. Now after I changed her name in my phone, when I ask Siri to txt my wife or her name, she will always put the original emojis in the text message or when I ask to call her, Siri just responds to, do you mean “this name plus the emojis”.

Is this any way to fix this?

I’m assuming this is an iCloud issue, but I can’t seem to figure out how to fix it. On the iCloud website her contact info is the same as my phone.
try deleting that entry, then reboot. then make a new clean entry with her contact info...
 

Pomeroy

macrumors 6502
Sep 27, 2008
318
9
Arkansas
Before I got married, my wife’s name in my phone was just her first name and then two emojis. Now after I changed her name in my phone, when I ask Siri to txt my wife or her name, she will always put the original emojis in the text message or when I ask to call her, Siri just responds to, do you mean “this name plus the emojis”.

Is this any way to fix this?

I’m assuming this is an iCloud issue, but I can’t seem to figure out how to fix it. On the iCloud website her contact info is the same as my phone.
[doublepost=1551650704][/doublepost]Try opening the Mail app and start a new message. Then start to enter the name of your wife. You will see a list of suggestions from contacts and the recently used email addresses. Tap the blue circle next to the email address you want removed. This will open the Recent screen. Make sure this is the email address you want to remove from autofill / autocomplete in iOS Mail. Tap the "Remove From Recents" button. From now on that old email address should not appear in the autofill list. I do the whole alphabet sometimes just to clear out Junk addresses that get in there from junk mail.
 

gc15

macrumors regular
Original poster
Oct 23, 2012
177
1
I tried all of those options. However, I did figure it out. So apparently I had my wife still saved with the emoji contact in photos as an album of people for photos to recongnize. Once I updated that, everything went back to normal.