Siri Issue: Sends iMessage to Dumbphones

Discussion in 'iPhone' started by FSMBP, Aug 25, 2013.

  1. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #1
    I'm having this issue with Siri. Whenever I ask Siri to send a message to my Grandpa (or anyone with a non-iPhone), Siri sends it as an iMessage. I've looked at all the usual remedies (resetting Siri, turned my iPhone off/on) but it won't work correctly.

    I even told siri "Send a Text Message to Grandpa" but it always defaults to an iMessage.

    FYI: In my example, my Grandpa never has or ever had an iPhone associated with his number. He has had the same dumbphone for 4 years. Also, his number isn't listed as an iPhone in my contacts.

    Anyone else have the same problem?
     
  2. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #2
    It usually defaults to blue iMessage bubble, but if it actually arrives as a text message the color will change to green.
     
  3. FSMBP thread starter macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #3
    Mine immediately says "Send Failure" as it tried to send an iMessage to a non-iPhone user.

    And I can confirm it doesn't go through to the other person.
     
  4. rf61985 macrumors member

    Joined:
    Mar 2, 2013
    #4
    This also happens when you go into photos and try to send a picture straight from there to a non iPhone. I wonder if this is still an issue in iOS 7. Anyone want to try it? Just make sure you have send as SMS off.
     
  5. rf61985 macrumors member

    Joined:
    Mar 2, 2013
    #5
    Here is what happens when you have Siri send an SMS to someone without an iOS device and you have "send as SMS" off.
     

    Attached Files:

  6. ocarina macrumors newbie

    Joined:
    Aug 25, 2013
    #6
    Love that show. :D
     
  7. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #7
    1. Look in the contact for your Grandpa. See whether his phone number is classified as iPhone or something else.

    2. Go into Settings, and see whether send as SMS is turned on.

    3. Set up genius bar appointment to have Apple take a look at it. (Or perhaps your carrier).
     
  8. Rayfire macrumors 68020

    Rayfire

    Joined:
    Aug 25, 2008
    Location:
    PNW
    #8
    It's fixed in the latest beta version of iOS 7, I can send to non-iPhone users and they receive them as SMS not iMessage.
     
  9. FSMBP thread starter macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #9
    Thanks! I figured it was a bug in iOS 6 as I setup up my iPhone as new and tried every which way to fix it.
     

Share This Page