General Siri Shortcuts don’t work on HomePod

Discussion in 'iOS 12' started by DerMario, Oct 8, 2018.

  1. DerMario macrumors member

    DerMario

    Joined:
    Jun 30, 2012
    #1
    Hey, I have several Siri Shortcuts under the Siri Tab in Preferences. I did one should play a Radiostation via Airplay on the HomePod.

    All Devices are latest Software....But the HomePod doesn't recognize the Phrase I recorded....the iPhone does.

    Can someone help me please...
     
  2. ryanmp macrumors newbie

    Joined:
    Dec 6, 2016
    #2
    Ahh... that’s completely untrue. HomePod supports Siri Shorcuts just fine and I’ve got a few that automatically airplay from the iPhone when activated.
     
  3. DeanLubaki macrumors 6502a

    DeanLubaki

    Joined:
    May 29, 2014
    Location:
    Toronto
    #3
    Ooo you're right! Apparently it has to be signed up to the same Apple ID for them to work. https://support.apple.com/en-us/HT209055
     
  4. DerMario thread starter macrumors member

    DerMario

    Joined:
    Jun 30, 2012
    #4
    Mine is on the same Apple ID.

    I already did a reset of the homepod.. No luck
     
  5. ZEEN0j macrumors 65816

    ZEEN0j

    Joined:
    Sep 29, 2014
    #5
    What do you mean automatically AirPlay?
     
  6. ryanmp macrumors newbie

    Joined:
    Dec 6, 2016
    #6
    So I have a Siri shortcut that:
    - Switches off various LIFX lights (linked to Homekit Scene)
    - Arms Arlo alarm system
    - Plays rain sounds from Apple Music

    When I run the shortcut from HomePod, the rain sounds are played from the HomePod.

    The only issue I'm having with this Siri Shortcut is the HomePod volume. I've used a System Volume shortcut, but that doesn't seem to change anything on the HomePod.
     
  7. MontTrain macrumors newbie

    Joined:
    Sep 10, 2012
    #7
    Not sure if it helps but I had a similar problem. If I ran the shortcut from Siri on my phone it worked but on HomePod it wouldn’t recognise it.

    The fix for me was that location services wasn’t set correctly on my iPhone.

    Settings - Privacy - location services - share my location from this device
     
  8. DerMario thread starter macrumors member

    DerMario

    Joined:
    Jun 30, 2012
    #8
    That was the key!!!! Thanks!
     
  9. ZEEN0j macrumors 65816

    ZEEN0j

    Joined:
    Sep 29, 2014
    #9
    Ok so it wasn’t actually airplay. The HomePod is playing the song. It would be nice if you could make a shortcut, run it on your phone and it started playing on a airplay speaker.
     

Share This Page

8 October 8, 2018