SL: Turn off https in Safari?

Discussion in 'macOS' started by moonman239, Mar 22, 2012.

  1. moonman239 macrumors 68000

    Joined:
    Mar 27, 2009
    #1
    I think https isn't working on my profile. The strange thing is, it might be just me. Instead of trying to fix the problem, I'd rather use nonencrypted HTTP. Apple, is it really too much to put in a checkbox in Saafari's Preferences panel to enable or disable encryption?

    Oh, and I only want this to affect me since I almost never do any banking on my profile.

    Meanwhile, I will use Firefox, which also can't establish a secure connection, but at least the https switch isn't glued in the ON position.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    You say you aren't doing any banking, but turning off HTTPS altogether would be the LAST thing I would try if I were having connection problems.

    The tab I view my RSS feeds is not encrypted but the tab where I read my email (and have to log in from time to time) is always encrypted. To me, any computer without the ability to do encrypted browsing is a badly broken computer and given a choice I would not use it.

    If you're having problems in one browser, try downloading a completely separate browser such as Opera and test things there. Another thing to try is creating a separate test login on your Mac and see if the problem affects browsing using the test login. Also take a look at your OSX firewall settings. You can switch it off for testing then switch it back on again if it didn't make a difference.
     
  3. jackhdev macrumors 6502

    Joined:
    Apr 9, 2011
    Location:
    Bismarck, North Dakota
    #3
    Try using a different browser and test connections for port 443 on canyouseeme.org. Attempting to not use HTTPS can have some negative results: everything you do will be unencrypted, some websites will flat out just not work (because they REQUIRE all connections over HTTPS), among other things. You can always bring your Mac to the Genius Bar or wipe it and restore your home folder as a last resort.
     

Share This Page