Smart Cover not making a secure connection to the spine of the iPad.

Discussion in 'iPad Tips, Help and Troubleshooting' started by BobaFettucini, Mar 14, 2012.

  1. BobaFettucini macrumors newbie

    Joined:
    Apr 19, 2009
    #1
    My fiancée and I both have iPad 2s. Since we got them, we've noticed that her smart cover spine doesn't hold onto the iPad as well as mine, and sometimes detaches in viewing mode, or if not picked up very gently by the rolled cover. Mine, however, doesn't have that problem. We assumed it as the smart cover itself, but have since tested out both iPads with both smart covers, and came to the realization that the smart covers don't hold onto the top left corner of the iPad (in portrait mode) very well at all, whereas both of our covers attach to mine just fine.

    If we go to the Apple store and explain/demonstrate the problem, will they do anything about it? I've dealt with them many times over the years, and they're always glad to help, it just feels like they might view this as petty. We just feel that it's one of the main features of the iPad, and that eventually her iPad may take a mortal blow because of this.
     
  2. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #2
    have you tried cleaning the magnet surface on the smart cover where it attaches to the ipad? i noticed after awhile mine got dirty and wasnt sticking as well as it was when new. Cleaned it up and it stuck much better
     
  3. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #3
    It'd also be worth having Apple look at it. I could be wrong but vaguely remember someone having an iPad2 in which one of the magnets was installed backwards.
     

Share This Page