Snow Leopard cannot mount DVD

Discussion in 'macOS' started by adamk77, Aug 29, 2009.

  1. adamk77 macrumors 6502

    Joined:
    Jan 6, 2008
    #1
    Is anyone running into problems mounting DVDs?

    It's not consistent. Leopard is able to mount it, but Snow Leopard is not able to mount certain DVDs.
     
  2. adamk77 thread starter macrumors 6502

    Joined:
    Jan 6, 2008
    #2
    I figured out why it wouldn't mount.

    If you did not label your DVD, it will not mount. And because I am using the superdrive connected externally via a USB cable, I could not eject the disk.

    There's a way to eject the disk from the command line though:

    Run the command

    drutil eject

    and it will eject the disk.
     
  3. cropduster macrumors newbie

    Joined:
    Aug 29, 2009
    #3
    I have the same problem mounting recorded dvds without names. I burned them in Toast 10 in Leopard without a name & they mounted fine as a "untitled UDF volume". In Snow Leopard they will not mount. Toast still sees them & will do a disc copy, they just won't mount automatically or using disk utility.

    I hope someone can find a way round this, I have nearly 400 such dvds.

    All other discs mount ok.
     
  4. adamk77 thread starter macrumors 6502

    Joined:
    Jan 6, 2008
    #4
    Figured out how to mount it

    cropduster,

    I figured out how to mount it. You'll have to mount it manually from the command line. You'll have to first figure out which device your superdrive is under the /dev directory.

    First put in a DVD that is actually mountable into the superdrive. Once it's mounted, go to terminal and type the df command and it'll show you which /dev/device it is. For me, it's /dev/disk2. Eject the DVD in the superdrive.

    Now, put in the DVD that is not mountable (because it's missing a label).

    Open up terminal, and type:

    sudo mount_cd9660 /dev/disk2 /Volumes/CD

    If the directory /Volumes/CD doesn't create, you have to create it first.


    I think this was a minor oversight by the programmers. It should most likely be fixed in the next update/patch.
     
  5. cropduster macrumors newbie

    Joined:
    Aug 29, 2009
    #5
    Hi, thanks very much, I managed to mount the DVD ok.
    Only thing is I cannot unmount it however I try. I tried:

    disktool -u diskXYZ
    disktool -e diskXYZ
    hdiutil eject /dev/diskXYZ

    The disc is always busy (it shouldn't be).
    Tried force eject & via disk utility, still won't eject. I'll reboot in a mo then eject it, but do you know how I can force eject discs, otherwise I will have to read them in my Linux machine or restore the time machine backup I made before installing SL until they fix this.

    Thanks again for the help.
     
  6. adamk77 thread starter macrumors 6502

    Joined:
    Jan 6, 2008
    #6
    I am able to eject without any issues. I am doing the following:

    sudo umount /Volumes/CD
    sudo drutil eject

    Where /Volumes/CD is the directory you mounted it to.

    I hope this helps
     
  7. cropduster macrumors newbie

    Joined:
    Aug 29, 2009
    #7
    Hi, it did help, all works ok now, thanks very much for your time.
     
  8. iphonetune macrumors newbie

    Joined:
    Aug 20, 2009
    #8
    Easy solution found finally

    I had the same prob after upgrading to SL on my MacBook Pro 15" 2.2 Core2D.

    I had already fresh reinstalled SL to no avail.

    This has fixed it for me;

    Goto System preferences > CDs & DVDs > When you insert a video DVD > IGNORE

    good luck

    Robin
    http://iphonetunes.net
     
  9. 10-K macrumors newbie

    Joined:
    Apr 15, 2010
    #9
    Disk Utility

    I've found a DVD will mount as soon as I launch disk utility.
     

Share This Page