So... Anyone try booting from the recovery partition of 10.12 yet?

Discussion in 'macOS Sierra (10.12)' started by serr, May 4, 2017.

  1. serr macrumors regular

    Joined:
    Mar 8, 2010
    #1
    ... because Apple obviously didn't!

    You get the circle/slash like trying to boot from an unsupported OSX install with a too old machine.
    I did 3 clean installs to verify this wasn't a red herring. Two different machines as well.

    Wow...

    Personally, I use CCC for backup needs. I only discovered this after someone alerted me to it and I tried it on my machines.

    This is really starting to feel like the end of Apple and OSX. :(
     
  2. FrancoisC macrumors 6502

    FrancoisC

    Joined:
    Jan 27, 2009
    Location:
    Montreal, Qc
    #2
    I did just now and it worked perfectly. If you have Applecare, call Apple maybe at this point?
     
  3. serr thread starter macrumors regular

    Joined:
    Mar 8, 2010
    #3
    Interesting. What model?
    I'll have to test a few more. Maybe it only comes up with certain models.
    All hardware passes all tests. Running 10.12 fine (some of the other faux pas aside). Said friend had a bad hard drive which can and did cause kernel panics.

    No Applecare and I'm just not going to go to the Apple store to watch the poor genius bar people jump through hoops for a software issue.

    Not stuck here or anything. This was discovered as an aside to something else. Just thought the discovery was worth mention. Maybe it's only with certain machines? Still sloppy.
     
  4. FrancoisC macrumors 6502

    FrancoisC

    Joined:
    Jan 27, 2009
    Location:
    Montreal, Qc
    #4
    Mac mini late 2012 here. Which ones for you?
     
  5. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #5
    That's why it doesn't work; the Recovery OS has to be patched just like the normal OS for it to boot on an unsupported Mac (and Apple doesn't test software on unsupported hardware, hence why it's unsupported). I'm not sure if @dosdude1's utility provides this functionality, but I do know it's possible to do manually.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Another 2012 mini here, with 10.12.5, which boots to recovery partition just fine.
    I don't usually boot into recovery, but I boot to a USB Sierra installer, which gives much the same functionality of the recovery, with a bit more flexibility.
    Anyway, just to test, the recovery partition is good.

    It would be helpful to know which Macs you have, and what external devices you might have connected (if any)

    You did say 10.12.... Do you mean most recent install version 10.12.4?
     
  7. serr thread starter macrumors regular

    Joined:
    Mar 8, 2010
    #7
    I did a little searching on this and I see a great many forum posts reading 10.12 the riot act over missing/breaking things on a number of slightly older machines. I downloaded the patch tool from Dosdude (http://dosdude1.com/sierrapatch.html). Ran it, checked the box for 'patch recovery volume' and now the recovery volume boots.

    Cool that someone had a fix already! :) Pretty unimpressed with this level of sloppiness from Apple. :(

    I don't really even use the recovery partition so it's kind of a moot point. I accidentally stumbled across this. I use CCC and manage my own backup volumes.

    Let's see...
    - Recovery partition broken out of the box.
    - Half implemented light tap drag lock feature that instead ends up making it seem like your track pad is intermittently less responsive.
    - A couple services that call home every 5 seconds and Apple service claims to not know what they are (eye rolling emoji here).
    - They changed the gatekeeper 'allow everywhere' option to hidden by default but forgot the preference option to unhide it (requires a terminal command).

    This is the kind of sloppiness that I used to make jokes about Windows for.

    I did try all this with both the clean install and the update to 10.12.4. The .4 update didn't fix anything.
     

Share This Page