Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

[SOLVED] Big sur failed Update to beta 5


macrumors newbie
Original poster
Aug 21, 2020
A while ago I noticed spindump hogging my CPU constantly (>80%). I found a thread which I followed to disable spindump

Commands I ran from recovery:

csrutil authenticated-root disable
mount /dev/disk3s5 /Volumes/osvolume

bless --folder /Volumes/osvolume/System/Library/CoreServices --bootefi --create-snapshot

After that, all OS updates are failing with the message below:

Failed to download & prepare update: Error Domain=SUMacControllerError Code=7740 "[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)|FullReplacementRequired|]" UserInfo={SUMacControllerErrorIndicationsSummary=|FullReplacementRequired|, SUMacControllerErrorIndicationsMask=2, SUMacControllerErrorIndicationsDescription=-> Full replacement is required [as opposed to incremental patch]., NSUnderlyingError=0x7ffb14c19680 {Error Domain=MobileSoftwareUpdateErrorDomain Code=3 "'./System/Library/CoreServices/boot.efi.j140kap.im4m' has been added" UserInfo={target_update=20A5354i, MSUFullReplacementRecommened=true, NSLocalizedDescription='./System/Library/CoreServices/boot.efi.j140kap.1928DA36E30026.im4m' has been added}}, NSDebugDescription=[SUMacControllerErrorPrepareFailed=7740] Failed to perform Prepare operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_FILESYSTEM_DOESNT_VERIFY(3)|FullReplacementRequired|], NSLocalizedDescription=Failed to prepare the software update. Please try again.}

I tried going back to recovery and doing csrutil authenticated-root enable, I set the startup security to Full Security
However, still doesn't update.

From my understanding, I need to reverse the bless command to go back to original signed snapshot.
Is there any command to undo the bless --bootefi --create-snapshot ?


I booted to recovery and removed boot.efi.j140kap.im4m but after running bless to make the mounted drive bootable again, the boot.efi.j140kap.im4m file gets recreated. Update fails again with the reason './System/Library/CoreServices/boot.efi.j140kap.im4m' has been added'

Still can't get it to work



I gave up being a smartass, booted to recovery and pressed "Reinstall Mac OS".
New update was automatically installed, none of my data was lost. Everything is good now.
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.