SOLVED ?? (hopefully) Installed Mavericks and Now i Can't Connect to my WiFi

Discussion in 'OS X Mavericks (10.9)' started by vmaniqui, Oct 23, 2013.

  1. vmaniqui, Oct 23, 2013
    Last edited: Oct 24, 2013

    vmaniqui macrumors 6502a

    vmaniqui

    Joined:
    Mar 8, 2013
    Location:
    California
    #1
    i just installed the new MacOS Mavericks and suddenly i can't connect to my WIFI. my iPhone, iPad can connect and yet my MBPro can not. i tried all possible solution and tried re-installing the Mavericks but no luck anyone has any idea or solution. Appreciate it.
     
  2. Martyimac macrumors 6502a

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #2
    Three things to try,
    1. Shutdown then restart, look for your wifi and join.
    2. Reset SMC
    3. Reset PRAM

    That's all I have, good luck.
     
  3. maddux530 macrumors newbie

    Joined:
    Oct 5, 2011
    #3
    Same thing happened to me on my upgrade from 10.8 to 10.9. A simple restart fixed it for me. Resetting SMC should help, too.
     
  4. vmaniqui thread starter macrumors 6502a

    vmaniqui

    Joined:
    Mar 8, 2013
    Location:
    California
    #4
    tried this and didn't work. it was working perfectly last night but as soon as Mavericks is installed i got this WIFI issue. i checked online and followed all possible solutions but nothing. my iPhone is ok and so is my IPAD. can't really understand why i can't connect to my WIFI with this new MAVERICKS. i will try and install my old Snow Leopard it it will let me. otherwise i am really ready to throw out the towel. i have been trying to fix this since this morning and can't come up with a solution. hopefully someone can give me a solution. thanks.
     
  5. vmaniqui thread starter macrumors 6502a

    vmaniqui

    Joined:
    Mar 8, 2013
    Location:
    California
    #5
    i gave up and just decided to use DCHP with manual address. not the best solution as i have to switch back and forth and could be a potential issue when i use other peoples wifi but for now will suffice. i have no idea what happened. i might reinstall mavericks and hopefully that will resolve my issue. this is a pain.
     
  6. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #6
    Did you contact Apple?
     
  7. vmaniqui thread starter macrumors 6502a

    vmaniqui

    Joined:
    Mar 8, 2013
    Location:
    California
    #7
    have not. i am thinking since this is a free download, support will be minimal.
     
  8. masands macrumors regular

    Joined:
    Sep 17, 2010
    #8
    My Wifi has gone as well. Was working perfectly last night on Mavericks but won't connect today at all.
     
  9. vmaniqui thread starter macrumors 6502a

    vmaniqui

    Joined:
    Mar 8, 2013
    Location:
    California
    #9
    Up until now I can't seem to resolve my issue. I am writing this on my ipad which can connect to my wifi. Whole day of work and can't fix it. So frustrating. Grrrrhhh
     
  10. vmaniqui, Oct 24, 2013
    Last edited: Oct 24, 2013

    vmaniqui thread starter macrumors 6502a

    vmaniqui

    Joined:
    Mar 8, 2013
    Location:
    California
    #10
    i may have found a solution (knock on wood) and hope my WIFI stays connected. what i did was to re-install Mavericks from APP STORE. but here's the tricky part - you can't download Mavericks from APP STORE as it will detect your OS version as up to date so you need to do a SUDO NANO edit on your System.plist and change SW V from 10.9 to 10.8. that way APP STORE will see that you have an old version and you can upgrade to MAVERICKS and MAVERICKS will download and install. as soon as it's done installing, i restarted my MBP and noticed that my WIFI signal icon is ON. i will see tomorrow if it's still OK. imagine, i've worked on this issue since 10am (oct 23) this morning and it's now 1:41am (oct 24).
     

Share This Page