Some weird bugs with 2.2.1 ive noticed the last couple of days!

Discussion in 'iPhone' started by Rob Mclovin, Feb 4, 2009.

  1. Rob Mclovin macrumors 6502

    Joined:
    Jul 24, 2008
    #1
    Noticed that on 2.2.1, your iphone will freeze randomly, and you wont know it till you try to use it. Ive had this happen 3 times, where i take out my iphone, and the phone is stuck on a dead black screen, if you try to turn it on maybe thinking it just turned off, it wont work. You have to do a hard reset for 10 seconds, then only the apple logo will come up.

    Today when i was leaving class and walking to my car, this dude just quickly walks up to me, and gets close fast and says "My phone wont turn on", he didnt have his phone out yet so im like, is he gonna try to stab me, or just steal my phone!? Takes his phone at, and has the same problem as me, so obviously its not just my phone.
     
  2. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #2
    :eek: May I suggest...running away?
     
  3. kas23 macrumors 603

    kas23

    Joined:
    Oct 28, 2007
    #3
    This is really strange. I just don't know what else to say...
     
  4. Rat-Boy macrumors 65816

    Rat-Boy

    Joined:
    Jul 28, 2008
    Location:
    Georgia
    #4
    If it is what think I have learned about this phone, it's that every person seems to have issues that others don't.

    This has never happened to me and I installed 2.2.1 the day it came out.
     
  5. kas23 macrumors 603

    kas23

    Joined:
    Oct 28, 2007
    #5
    You never had some random dude come up to you and tell you his phone is broken? ;)
     
  6. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #6
    Used to happen to me all the time on 1.1.4 but never once since I upgraded :D
     
  7. Rat-Boy macrumors 65816

    Rat-Boy

    Joined:
    Jul 28, 2008
    Location:
    Georgia
    #7
    LOL...

    Nope, not that either. :D
     
  8. LinMac macrumors 65816

    Joined:
    Oct 28, 2007
    #8
    I don't have a lot of iPhones to test for reference, but my iPhone and iPhone 3G don't have this problem. I just called a friend to ask if his has had that problem, but he hadn't experienced it.

    Have you tried to do a full restore?
     
  9. dissdnt macrumors 65816

    dissdnt

    Joined:
    Aug 3, 2007
    #9
    I've noticed a new bug, anyone see this?

    Keyboard icons don't highlight or get bigger when you type sometimes.

    It fixes itself if you hit home and go back to what your doing, but never saw that before.
     
  10. LinMac macrumors 65816

    Joined:
    Oct 28, 2007
    #10
    What program(s) are you using when you see this error?
     
  11. macfearless macrumors regular

    Joined:
    Jan 15, 2008
    #11
    i haven't even upgraded to the newest update and mine has been doing that for about a month now. It does it while texting and in Safari... pretty annoying.
     
  12. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #12
    gah! I hate that issue! I can't stand it, it makes it next to impossible to type in passwords.
     
  13. svndmvn Guest

    Joined:
    Nov 6, 2007
    Location:
    Italy
    #13
    it's a 2.2 safari bug I used to have a lot more..less in 2.2.1 now
     
  14. dissdnt macrumors 65816

    dissdnt

    Joined:
    Aug 3, 2007
    #14
    Typing issue, usually Safari.

    Glad other people are having the same issue. Well not glad, but at least it's wide spread so it might be addressed someday :)
     
  15. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #15
    That's been happening to me since 2.2 (in Safari only). Still does it in 2.2.1. I'm hoping for a fix soon.
     
  16. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #16
    This happened to me once on 2.2.1.
    I've never had it feeze, but it did just shut off randomly.
    Only thing that really pissed me off is, it took me like half an hour to get the damn thing to restart!:eek:
     
  17. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #17
    Anyone ever go to unlock their phone by pressing the home button... then realize the screen didn't come on, so you press it again and the screen comes on and goes back out... so you press it again and the screen finally comes on? This has happened on all my iPhones and my girlfriend's iPhone.
     
  18. Eric Isaacson macrumors 6502

    Joined:
    Jul 30, 2008
    #18
    I haven't encountered this bug but I have had another one.

    My phone will ring but the screen remains off. If I turn the phone on to answer the call it doesn't show I have a call. It keeps ringing with no way to answer and then goes to email.
     
  19. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #19
    Yep! It's not a major issue and I've noticed this since 2.0. I think it might just be a little slow response time, too much memory being used, or maybe telling it to do too many things at once.
     
  20. dissdnt macrumors 65816

    dissdnt

    Joined:
    Aug 3, 2007
    #20
    Yah i've had the problem for awhile. Sometimes I have to hook it up to a power source for it to pop on.

    I think it happens when it's grabbing or checking mail so it's all busy and starts getting laggy between button presses.
     
  21. diggator macrumors member

    diggator

    Joined:
    Nov 12, 2008
    Location:
    Jacksonville/Orange Park, Florida
    #21
    Im having some problems also... Seeing the same as mentioned above (hitting keys and not seeing the number display, etc.. Sudden lock up - ) But most recently last night, the phone got super super hot when charging - then its telling me that i have 10% batter left, while its on the charger... Never happened before...
     
  22. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #22
    I think you're probably going to be heading back to the Apple shop judging by previous threads about that problem
     
  23. StingerT125 macrumors 6502a

    StingerT125

    Joined:
    Jun 3, 2008
    Location:
    Dutchess County New York
    #23
    I haven't noticed any difference since upgrading.
     

Share This Page