Someone shoot me :( Accidentally put appleworks in trash

Discussion in 'Mac Apps and Mac App Store' started by 1rottenapple, May 12, 2004.

  1. 1rottenapple macrumors 68000

    Apr 21, 2004
    Ok so I am deleting a ton of stuff and accidentally, somehow, appleworks got into the trash. No I press the empty trash, then it says something to the effect "item (the appleworks) is locked" can't be deleted. Now the apple works logo in the dock has become a regular blue folder, and everytime I double click it, nothing happens. A square "grows" each time I click it, but nothing appears. Why does something bad always happen when I am working on my car or computer?

    Any clues as to how I get back the appleworks, without reformating my computer, and losing all my settings? If not, I guess I can stay with word.
  2. HexMonkey Administrator


    Staff Member

    Feb 5, 2004
    New Zealand
    I suspect what has happened is the following:
    On Mac OS X, most applications are actually folders in disguise. Inside are a number of files, such as interface files, images etc. If one of these files has been locked for some reason, and you try to delete the application, then all the files inside the application, except the locked one, will be deleted. The application cannot run without the deleted files, so you will no longer be able to run it.

    Now the solution:
    Insert your software restore disc, and then in Finder go to Go->Go to Folder... (command-shift-G). Type in "/[Name of software restore disc]/.images". This should open a folder with a number of disk images. One should be called "AppleWorks.dmg". Mount this by double clicking it, then navigate through it to find the AppleWorks application (AppleWorks->Applications->AppleWorks 6). Copy this to your hard disk, then unmount the disk image and eject the disc.
  3. 1rottenapple thread starter macrumors 68000

    Apr 21, 2004
    Whew... I don't have to format anything... YAY imo.

    A cool feature for the forum would be a rating system for the helpful users.
  4. satty macrumors 6502

    Mar 1, 2004
    You can't beat Wellington on a good day
    How did you delete it in the first place?

    I just tried to move an application into trash and I got a window to insert an Adminstrators user and password, before doing so.

    Now I assume, because you didn't mention it, that you did not have to authenticate and so you're working as an Administrator. :eek:

    From all my experience I have (dozen years in IT incl. Windows, Unix, Mac...), I would not advice to do so for standard work you have to do on your computer, i.e. Mail, Internet, writing letters and so on.

    Create another non-Administrator user for your daily work and do only system maintenance as an Administrator.
    Mac OS X is very cool in this case and just asks for the Administrator password, if you want to install or delete an Application, so you don't have to logout/on.
  5. Horrortaxi macrumors 68020


    Jul 6, 2003
    Los Angeles
    Probably because you don't completely understand what you're doing with them. I'm not trying to be mean by saying that, but cars and computers are my hobbies. I know a lot about them and I read message boards, and in both cases when there are big problems it's nearly always because the user did something dumb.

    Getting AppleWorks back: Have you tried to drag it from the trash back to the Applications folder? If it wasn't deleted then that should work.

    There is no reason you'd have to reformat your hard drive because of this. Maybe it's that kind of thinking that gives you problems with cars and computers.

    At worst, you would have to reinstall AppleWorks from your Software Restore CD or retail CD, depending on how you acquired the program.

Share This Page