Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

flow2345

macrumors newbie
Original poster
Sep 8, 2014
1
0
This is a problem that has been irking me for the past week or two.

Whenever I add new files to my library, some of these new files only play until 1:12 and then skip to the end. The skipping point is sometimes 2:00 or 3:00, but mostly 1:12.
If I convert these files to AAC files, they are 1:12 minutes long. (or 2:00 and 3:00 if those are the skipping points)
This seems to be happening randomly and the song can actually play beyond 1:12 if I start playing at a point after 1:12.
The files itself are not corrupt, as I have been able to successfully play them beyond 1:12 with other players (VLC, Windows, etc)

There is nothing wrong with the start time and end time, and I also have tried re-installing iTunes, but the problem still remains.

I also tried re-adding the problematic files, but they rarely have ever succeeded.
The only times this succeeds is when I converted the corrupt files to M4A (or any other compatible format) through a 3rd party software, and re-added them again. Sometimes, even this doesn't work.

Does anyone have a solution for this?
I've seen this thread (https://forums.macrumors.com/threads/1756257/) but it didn't help all that much.
 

Krafty

macrumors 601
Dec 31, 2007
4,439
308
La La Land
Seeing as you linked my thread and I'm still having this issue, hoping that maybe iTunes 12 doesn't when 10.10 drops, the only thing I noticed is this issue popping up in the console:

Screen_shot_2014_10_12_at_10_06_32_PM.png


But after searching google, I don't know what it is or how to cure it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.