HomePod Sorry, you’re not listening to Apple Music

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by mcdspncr, Jul 1, 2018.

  1. mcdspncr macrumors regular

    mcdspncr

    Joined:
    Jul 2, 2011
    #1
    So just wondering if others are also getting this message, and if anyone has insight as to why? Since the last update to HomePod that added airplay 2.0 and Apple TV support I now frequently get this response: Me “hey siri, play X playlist.” Siri “ I’m sorry I can’t do that, you’re not currently listening to Apple Music.”

    At first I thought this was related to previously watching YouTube or something on the Apple TV with the AirPods acting as audio out. But it even happens when the Apple TV has been asleep for over a day. And even when the Apple TV is on the homepage with no apps running.

    Any idea what’s causing this, and how to stop it? I’ve been working around it but waking the Apple TV, booting up Apple Music and manually selecting playlists. I would think that the AirPod would prioritize any verbal requests over whatever it thinks it is supposed to be doing.
     
  2. Topfry macrumors member

    Joined:
    Apr 19, 2011
    #2
    I’ve found a similar thing happens if I’ve used airplay on the Apple TV to watch a film; you have to make sure that the HomePod is unchecked on the ATV in audio options or else it will appear responsive but not allow you to play any songs. The ATV is basically continuing to control the HomePod.
     

Share This Page