Sound coming out of both headphones and speaker on 3g iPod touch

Discussion in 'iPod touch Accessories' started by yayitsezekiel, Dec 26, 2009.

  1. yayitsezekiel macrumors 6502a

    yayitsezekiel

    Joined:
    Aug 1, 2008
    Location:
    Irvine, CA
    #1
    Hey guys, I recently picked up an iPod touch 3rd generation and when I plug in headphones, it plays from both the internal speaker and the headphones. But on the headphones, the volume is constant. Meaning that I can move the volume slider and the volume doesn't change; only when I move it to the very far left the volume shuts off. Anyone have this problem or have heard of it? I googled it and not much came up. Is there a button I have to press or a setting I need to change? If it makes a difference, it is jailbroken via blackra1n.

    Thanks
     
  2. TraceyS/FL macrumors 68040

    Joined:
    Jan 11, 2007
    Location:
    North Central Florida
    #2
    I have no clue if the JB could have caused it - but are you sure they are pushed in all the way? Do you have a case that is maybe preventing them from clicking that last little bit?

    Apple will want to see a full restore and set up as new before they would replace as a hardware problem - so you might go ahead and try that if it isn't the headphones not being in (i had this happen to myself once).

    Hopefully it is something easy!
     
  3. Lumify macrumors newbie

    Joined:
    Jan 8, 2010
    #3
    I think I found a fix

    I know this is sort of late, but I've had the same problem and I've fixed it with mine. Try rebooting the iPod (completely turning it off and on) with headphones plugged in the entire time throughout the reboot. Once it is booted, it should be fine to remove and put back in the headphones whenever you want. I don't know if this will work for you, but it has consistently worked for me.
     
  4. shinedown87 macrumors newbie

    Joined:
    Mar 27, 2010
    #4
    Thank you. This does work. The only problem is that it keeps happening. Unfortunately I have the 3g iPod Touch and it is a tethered jailbreak. So instead of simply turning the phone off and then back on, I am limited to only doing this when I am around my computer.

    Does anyone have any other fixes, or suggestions to keep this from happening?

    Thanks!
     
  5. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #5
    I had that problem with my 2nd Gen touch, it just needed to be restored. Never had the problem after. But then you will end up loosing your jailbreak.
     
  6. Orli155 macrumors newbie

    Joined:
    Feb 11, 2010
    #6
    If you have insomnia, then that is causing the problem. If you do then just turn insomnia off and put it to sleep for about 20 seconds, and everything will work like normal.
     
  7. KnightaWk macrumors newbie

    Joined:
    May 7, 2010
    #7
    thx shinedown87 & Lumify for the tip

    hey guys...it works for me too..but the big question is why did that happen??o.0
    are your ipod touch 3rd gen and jailbroken with blackrain?
     

Share This Page