(Sprint) Cannot use Wifi - But can use 3G

Discussion in 'iPhone' started by Garvorious, Feb 26, 2013.

  1. Garvorious macrumors newbie

    Joined:
    Feb 20, 2013
    #1
    Hello,

    After jailbreaking my iPhone, I noticed after trying to access Cydia or the App Store, they continuously load forever, or give me the "cannot access to server" error.

    I thought I did something wrong during jailbreak/installation, however, I realized it was my internet.

    Now, if I attempt to connect to applications/safari/app store/cydia via 3G (I have Sprint), everything works like normal. The downloads are slow, and I cannot download any application that are 50MB or higher (unless I have Wifi)

    Now, when I connect to my Wifi network, things stop working. I can no longer access the App Store/Cydia (infinite loading), and if I restart springboard, it works for a moment, then goes back to the freezing, and applications "install" forever as well (they don't download). Safari also gives me "cannot access server" errors when I google something.

    Now, I have no idea what I did wrong, but is it the iOS problem? Or is there a simple fix I can do?

    I've tried these method:

    Full factory reset restore
    Hard reset (home + lock)
    "Renew Lease"
    Reset Network Settings

    Each come with the same results - nothing.

    Any more tips or help will be greatly appreciated.
     
  2. quietstormSD macrumors 6502a

    quietstormSD

    Joined:
    Mar 2, 2010
    Location:
    San Diego, CA
    #2
    Have you tried more than one wifi network. Because it may be the network. I know my iPhone's internet connection always craps out when it tries to connect to AT&T wifi networks in Starbucks.
     
  3. Garvorious, Feb 26, 2013
    Last edited: Feb 26, 2013

    Garvorious thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #3
    I just tired using my other Wifi and I managed to get connection to download speedtest app.

    However, when I connect back to the wifi I was having trouble with, it's showing I have ping, download, and upload speeds. Meaning it's connecting with the internet, but for some reason it refuses to do anything.

    Edit: Now it won't find a server.
     
  4. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #4
    DumbQ: Do you have any other devices on this WIFI? Have u done any configuration to it lately? Do you have admin access to this WIFI?
     
  5. Garvorious thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #5
    Several computers, yes. But my iPhone on iOS 5 and below (not to mention my iPad prior iOS6) never had this issue before.

    Configuation to the router or my iPhone? I upgraded to iOS 6 and Jailbroke it using envasi0n 1.4.

    I do have admin access to the wifi.
     
  6. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #6
    Not before, RIGHT NOW, if you other devices can do WIFI then there's something wrong with the phone.
     
  7. Garvorious thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #7
    Yeah, which is why I want to know what I need to do to fix this issue...
    iOS 6 has been nothing but trouble for me.
     
  8. dextr3k macrumors 6502

    Joined:
    Nov 26, 2012
    #8
    I remember reading a post where the user had to reset the router and the iphone in order to get a stable connection. Maybe try that?
     
  9. Garvorious thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #9
    Did that too, same results.
    This is really bothering me.
     

Share This Page