SSD Will Not Format in Optical Bay? (Early 2011 MBP, Lion, Samsung 830 SSD)

Discussion in 'MacBook Pro' started by The Arin, May 25, 2012.

  1. The Arin macrumors newbie

    Joined:
    Dec 11, 2010
    #1
    Computer Specs:
    Early 2011 17 Inch MBP
    2.3 GHZ Intel Core i7
    16 GB 1600 MHz DDR3
    AMD Radeon HD 6750M 1024 MB
    Mac OS X Lion 10.7.4 (11E53)
    No software updates available

    Serial-ATA Device Tree:
    -Intel 6 Series Chipset
    -- Product - 6 series chipset
    -- link speed - 6 gigabit
    -- negotiated link speed - 3 gbit
    -Intel 6 Series Chipset
    -- Product - 6 series chipset
    -- link speed - 6 gigabit
    -- negotiated link speed - 6 gigabit

    Hard Drive Specs
    Samsung SSD 830 (MZ-7PC512N)
    512 GB
    SATA 6 Gb/S
    Latest firmware from:
    http://www.samsung.com/us/support/owners/product/MZ-7PC512N/AM

    Optical Bay Drive Holder Specs
    MCZ Tech OptiBay
    http://www.mcetech.com/optibay/

    Problem:
    When I install my SSD in the Optical Bay, I'm unable to format and use the drive.

    I have two of these SSD's and I plan to copy my existing MBP hard drive to one of the SSD's and then run two 512 GB SSD's in my MBP.

    The SSD comes with a USB cable so I tested both drives with the cable. I can format both drives. Move files around. Restart and they still work.

    I started by putting one of the SSD's in the Optical bay to test it out and ultimately clone my existing HD to the SSD quickly. When I restart it says the drive needs to be initialized, even though it already was. If I try to format the drive it gets half way and just sits there without doing anything. I've let it sit for quite some time and nothing happens. If I keep retrying eventually I can get the drive to format and work. I can move files too and from the drive but when I restart the computer, the drive is gone and needs to be initalized again.

    I found Samsung has updated firmware so I had a coworker update the drives on his PC as that's the only way to do it.

    I then installed the drive back in my MBP and I have the same issue with the drive not initializing properly. I've cleared the Pram 5 times in a row and nothing changed. I even rebooted into some disk mode and tried formatting their, but that didn't work either. This is true for both drives I own. I have not tried moving the SSD to the primary HD bay and don't plan to do so until I can properly back up the drive. I checked the OS X Software update and I'm all up to date as far as I'm aware. I do not know how to check my MBP Firmware and I'm not sure if this is something I need to do.

    Has anyone experienced this issue and have any solutions?
     
  2. Jimbogiant macrumors member

    Joined:
    Feb 7, 2008
    #2
    I have the same MBP model, and had the exact same problem that you had- I had an OCZ Agility 3 (SATA III) that worked fine out of the main HDD slot, the original HDD worked fine with my Optibay, but the SSD just would NOT initialize when I put it in the ODD slot, did all of the things you described in your post... I think this (http://blog.macsales.com/11895-2011-macbook-pro-sata-problems-resolved) has something to do with it- apparently the MBPs that have SATA III ODD slots won't work with SATA III SSDs.

    I think the only way you can get a SSD to work and boot properly in that ODD slot is to use a SATA II drive.

    Hope this helps

    James
     
  3. The Arin thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #3
    So if I understand correctly, we lucked out and got SATA III in our optical bay, but must use a SATA II drive.

    Major bummer.

    Does anyone have any ideas if this will be addressed in the future with a firmware update since it doesn't appear to be a problem on the 13" MBP or is this an inherent problem that cannot be fixed with software?
     

Share This Page