SSDs in Sonnet Tempo Pro acting up–help!

Discussion in 'Mac Pro' started by pcievstb, Aug 11, 2014.

  1. pcievstb, Aug 11, 2014
    Last edited: Aug 11, 2014

    pcievstb macrumors newbie

    Joined:
    Oct 15, 2013
    #1
    Hi Guys,

    I’m running a 2009 Mac Pro (upped to 6c 3.46) that I configured a month or two ago. I bought a Sonnet SSD Temp Pro and two 840Pro and have been running them as System drives in RAID0 with great joy. Speeds where close to 900/900. I Installed TRIM Enabler and worked with the system for a while until I noticed that writing became quite slow. Today I checked Blackmagic Disk Speed test and the read speeds where very slow but the write speeds where abysmal!

    Like 173/570. Basically write speeds on par with my storage HDD’s. :(

    Here’s a short checklist:

    • Running 10.9.4
    • Drives Running in RAID0, no problems
    • Sonnet running in PCIE 2.0 x16 slot*
    • Trim enabled
    • 350 GB free from a total of ~1TB (2x 512)
    • Bootcamp is running but on a regular SATA HDD

    *I had them running in x4 but during troubleshooting I re-seated them to x16. No difference there. They ran at close to 900/900 in x4 before the speed declined.

    Does anyone have an idea what the heck is going on? I’m working with a lot of big tif files. No fun if the drives are not working as intended. :(

    /Edit:

    Here’s some interesting AJA results: [​IMG]
     
  2. hfg, Aug 11, 2014
    Last edited: Aug 11, 2014

    hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #2
    Is your "trim" still enabled? It gets reset when you do a OS X upgrade and you have to re-enable it each time.

    I have been running my 5,1 MP (12 core upgraded to 3.33GHz) booting OS X with a Sonnet SSD Tempo Pro with a pair of Crucial M4 512GB SSDs in RAID-0 for 1.5 years now with no problems. I have not seen any speed degradation using BlackMagic Disk Test over that period. I do have trim enabled and the 1TB array is about 3/4 full, as I offload archive stuff to hard disk occasionally.

    Initially I had it configured with a pair of 256GB Samsung 840 Pro SSDs and was seeing similar speeds as you posted (830w / 940r). The M4s have slightly slower write speeds however (505w / 926r).


    -howard
     
  3. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #3
    Thanks, hfg. I didn't know that about trim and OS updates. Indeed trim had been turned off.
     
  4. AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #4
    I need to bookmark this thread for all of the "OWC says TRIM isn't needed" posts! ;)
     
  5. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #5
    Enable TRIM, boot into single user mode, and run;

    fsck -fy

    You'll see that the last action fsck does is to trim your drives. Then type 'exit' to carry on booting. That should sort out performance issues.
     
  6. pcievstb thread starter macrumors newbie

    Joined:
    Oct 15, 2013
    #6
    I noticed that a few weeks ago but re-enabled it.

    Thanks for the suggestion. I’ve tried it and it is running and saying "Trimming unused blocks" but there’s no difference in performance. It’s still starting around 900mb/s for write, then declines in a split second down to under 225mb/s.

    [​IMG]
     
  7. pcievstb thread starter macrumors newbie

    Joined:
    Oct 15, 2013
    #7
    I let the mac pro idle overnight so trim can do it’s magic but still no change. I’m at a loss. No Idea wtf is wrong with these stupid ssd’s.
     
  8. h9826790 macrumors G3

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #8
    Did you try other benchmark software e.g. Blackmagic? Is the result consistent?
     
  9. pcievstb thread starter macrumors newbie

    Joined:
    Oct 15, 2013
    #9
    Yes. Same there. I uninstalled the SSDs from the Sonnet to test wether it’s a Sonnet or SSD problem. Turns out it’s the SSDs, Sonnet is fine.
     

Share This Page