Star Wars - The Old Republic runs fine on my early 2011 MBP 15"

Discussion in 'Mac and PC Games' started by DustinT, Dec 23, 2011.

  1. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #1
    Just in case anyone was wondering, I've been playing SWTOR a bit on my system and it runs just fine. When I play just on the laptop's screen, 1440 x 900, I play with medium detail and the frame rates are fine. On my external, 1080p display, I lower the graphics to low and can easily maintain playable frame rates around 25-30. Medium is just more than the system can comfortably handle at 1080p resolution.

    There are no upgrades on this system that affect graphics performance. I'm running the 6490 card and have the stock 4g ram. I have installed an OCZ Vertex 3 SSD but that doesn't impact frame rates in game, mainly just load times.

    Oh, everything I'm posting about here is under Window 7 32 bit edition thanks to Bootcamp.

    Finally, I've played quite a few MMO's in my time and I have to say the initial impressions I'm getting of this game are pretty positive. Bioware has certainly done their homework on this title and it shows. I like it.
     
  2. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #2
    Thank you for this. Googled and found this, so much appreciated. Specifically the 6490M, glad to hear it!
     
  3. DustinT thread starter macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #3
    Glad to help.
     
  4. Cyberludo macrumors newbie

    Joined:
    Jan 2, 2012
    #4
    Hello and thanks for these informations.
    I'm french and i just buy the game.
    I think i have the same MBPro like you
    Core i7, 4Go RAM and 6490M with 256 Mo RAM.
    Is it correct ?
     
  5. DustinT thread starter macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #5
    Yes, that's what I have too. Enjoy!
     
  6. Cyberludo macrumors newbie

    Joined:
    Jan 2, 2012
    #6
    Hello DustinT.:eek:

    do you meet framerate drops?
    By the time I get less than 20fps.:confused:
    Or even to 1-2 fps. It takes 1 to 2 seconds, but it's still annoying.:eek:
    Yesterday I had to get my resolution to 1200x800 to continue to play in good conditions.

    Do you encounter the same problems?

    Could you give me a list of your graphics settings?

    Thank you for your help.:)

    A +
     
  7. mikeyPotg macrumors 6502

    Joined:
    Mar 20, 2006
    #7
    I've been playing it pretty smoothly on my 2010 MBP with settings on low. My friend was actually surprised that it ran better on my bootcamp mac than his barely 2 year old desktop gaming PC.
     

Share This Page