Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Strange Mouse Click behavior after upgrading to iOS14 in RDP or Steamlink to Win10

Zumino

macrumors member
Original poster
Jun 7, 2011
31
7
Ok, this behavior is driving me up the wall, and I’ve got it narrowed down to exactly when it happens.
But I have NO idea what’s causing it, nor how to fix it.

I have a 2018 iPad Pro, and a simple 2 button+Scroll BT mouse.
When used in iOS, mouse works fine.
When I RDP(also when using Steamlink) into my Win10 desktop, the mouse button clicks get very “weird”.

Example:
To register a “right click”, I have to first left click where i want to right click, THEN I have to right click. This is effective maybe 75% of the time. The rest of the time, nothing happens.
If I just right click, nothing happens. I can click till the cow’s come home without anything occurring.

Screen behavior almost feels like the left click is “selecting” the button, which then allows the right click to ‘click’ it, which is just bizarre.
Sometimes clicking the Scroll wheel seems to work like a normal right click would, but sometimes it does not.
This behavior is consistent across three different BT mice, from the simple small travel mouse I normally use, up to a full ergonomic BT mouse that I usually use with my desktop.

On iOS13, mouse worked fine, no issues at all.
As soon as I updated to iOS14, this behavior started, and I have no idea what could even be causing it.

I have tried adjusting every mouse setting in iOS that I can find, without luck. If I switch the right/left click behavior in Preferences, the above behavior continues, just it is now mirrored.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.