Strange network problem - help!

Discussion in 'General Mac Discussion' started by MemphisSoulStew, Nov 3, 2004.

  1. MemphisSoulStew macrumors regular

    May 10, 2004
    Sorry about the length of this, but it's a weird one...

    Here's my setup:

    AMX-64 ADSL router with four ports:
    - eMac connected to the router by Ethernet cable
    - iBook connected to router by Ethernet cable
    - PBook connected via Airport Express which in turn is connected to the router by Ethernet

    Up until today I have had no problems with any of these connections. Today I finally got around to downloading and installing various security updates, the Java update and the latest QuickTime update on to the eMac. I initially had a few problems with the router and couldn't connect to the download site, but this was sorted out with a quick router restart and the downloads went smoothly and the software was installed with no problem. I have made no changes to the iBook and PB.

    My daughter has the iBook in her bedroom and some time after the eMac installs she complained that she was unable to connect to the 'net - she constantly got the Safari error message that Safari couldn't find the relevant server for any site. We tried IE but got the same sort of result: unable to find the server.

    The eMac was still able to connect so I suspected the iBooks Ethernet cable was broken. I took the iBook downstairs and plugged the cable from the eMac into the iBook and got the same unable to find server error message when I tried to connect. I plugged the same cable back into the eMac and connected straight away (in each case I tried to connect to

    Thinking the Ethernet port on the iBook was damaged I re-connected the cable and opened System Preferences > Network to find that an IP address had been assigned, implying that the Ethernet port was working.

    I woke up the PB, turned on the Airport, got a good signal and tried to connect to and that gave me the unable to find server message. I plugged the eMacs Ethernet cable (which I know is working) into the PB, checked that it had been assigned an IP address, and tried to connect to and it again failed to find the server.

    Next I moved the good Ethernet cable back to the iBook and tried to connect the PB to the iBook (which was still connected through the eMacs cable) and it worked, which could only mean that:

    - the PB was connecting to the router properly via the Aiport Express/Ethernet cable;
    - the iBook was connecting to the router via the eMacs Ethernet cable, so the iBooks Ethernet port was definitely working.

    I disconnected the two laptops then reconnected the eMac to the router with its normal cable, and succesfully connected the PB to the eMac.

    So ... by a process of elimination I have concluded that all my hardware is working correctly:

    1) the Ethernet port on the iBook is working as expected;
    2) the router is getting out to the net, as the eMac has no problem connecting (I'm typing on the eMac now);
    3) the eMacs Ethernet cable is good;
    4) the PBs Airport and the Airport Express are working correctly, and the AEx can connect to the router.

    I opened Network Utility on the PB and tried to ping the router itself - strangely enough this failed with the messages:

    ping:sendto:No route to host
    PING ( data bytes
    ping:wrote 64 chars, ret=-1

    --- ping statistics ---
    1 packets transmitted, 0 packets received, 100% packet loss

    I also tried to ping and immediately got the response

    ping:unknown host

    The speed of this response made me think that the request never even went out from the PB.

    So, in conclusion, it seems that:

    - the router is working - I can connect two computers succesfully through the router, and I can get out to the 'net through it (but only from the eMac);
    - the Ethernet port on the iBook is OK as I was able to connect it to the PB succesfully;
    - Airport on the PB is OK for the same reason that the iBooks Ethernet port was OK.

    So, given all the above, does anyone have any idea why I can't access the 'net from either the iBook or PB, even when they are connected to the router by the exact same cable as I succesfully use with the eMac?
  2. piatek macrumors newbie

    Oct 29, 2004
    hey i just got the same problem 2 - 3 days ago and i was going to post it now.
    in my case i have windows and os x both hooked up to a hub. i installed some updates yes. but i didn't even think of it.

    basically when i use internet on os x, internet on windows will be down but it STILL find the ip etc, and when i will use internet on windows first, i cannot use it on my mac.


    anyone any ideas ?

    thank you
  3. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    1) What IP range is the Airport Express handing out? You've said the ADSL router is using the 10.x.x.x range.

    2) Does the eMac still work if you move it to a different port on the router?

    3) When you hook the Powerbook or iBook up to the cable that the eMac was using, are you first releasing the eMacs IP address? I don't know anything about your specific router, but if it's doing any sort of MAC caching then there could be problems hooking a different computer up to that cable/port when it thinks there's already a different computer on that port.

    The simple way to eliminate that possibility would be to use that same known good cable, but plug it into a different port on the router when you try the laptops' Ethernet ports.

    4) I assume the PB can ping the Airport Express?

    5) Just asking another obvious question - when you say that "an IP address has been assigned", you mean in the correct IP range right? Because a port will almost always have some IP assigned, even if it can't connect to anything - in that case it'll be something like 169.254.x.x
  4. Mechcozmo macrumors 603


    Jul 17, 2004
    Have you tried restarting the router?

    Unplug power for ~10 seconds, then re plug it in. That solves most trouble. Also, does the router need a firmware update?
  5. MemphisSoulStew thread starter macrumors regular

    May 10, 2004
    Thanks for the replies -

    Mechcozmo - yep, I've unplugged the router and left it for a while, but no difference.

    Westside guy -

    1) 169.x.x.x

    2) Yes

    3) "are you first releasing the eMacs IP address" No. How would I do that?

    4) I hadn't tried pinging the Airport Express before, but I've just tried it and yes it can.

    5) Yes, 169.254.x.x

    I'll try running the updates on the laptops just to elimimate that, although I can't imagine why putting security updates etc. on the eMac would affect the other machines. I updated the eMac using Software Update which I obviously can't do with the laptops at the moment, so I'll have to get the updates off the eMac - where does Software Update put the downloads?
  6. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    Strange network problem - help!

    OK, a 169.x address means that the machine did not in fact get an IP address from the router/modem - the iBook gave up and assigned an address to itself. So not surprising that Web sites don't work.

    When you restarted the router, it seems as if the DHCP service was turned off, or is somehow being blocked from the two portables. Or the IP address of the router has been changed and the portables are not picking it up.

    The eMac *might* have a manual IP address... accounting for why it is still working. Does Network on the eMac say "Manually", "Using DHCP" or "Using DHCP with manual address".

    What happens if you take one of the portables and in Network using "Manually" set it to the same settings as the eMAc (including router and DNS Server entries) but make the portable's IP address one different from the eMac's?

    Remember, you only need a network connection and Appletalk to connect between machines and printers, you don't need Internet settings working properly for that -- if you can see the other Macs, you know the physical cabling is working.

    You need an IP address to get on your internal internet, and a DNS Server number to decipher web addresses so you can use style URLs as opposed to style.

    If you have a router/gateway, your machine needs to know its IP address in your internal network, in order to communicate to the outside world.

  7. MemphisSoulStew thread starter macrumors regular

    May 10, 2004
    Trevor - I'm at work now so I can't confirm anything at the moment, but:

    I'm pretty sure the Network setting for the eMac was "Using DHCP" rather than "Manually".

    I'm certain that I took the IP address of the router from the eMac then tried, unsuccesfully, to ping that same address from the PB.

    I'll try manually changing the PBs network settings when I get home from work this afternoon.

    One thing just occurred to me: I initally set up the router using a browser window on the eMac - could the security updates have screwed around with the router settings? Maybe I need to go through the router setup again? What about router firewall settings - could they be preventing the portables from getting out?

    And here I am stuck at work, when the important stuff is at home :rolleyes:
  8. MemphisSoulStew thread starter macrumors regular

    May 10, 2004
    Sorted ...

    In case anyone is interested I eventually reset the router to its original factory settings then went through the router set up again from a browser window, and all my connections are back as they should be. (There should be a phew! smilie)

    I'm presuming it was the security updates that messed it up for the portables, but I've got no way of proving that. I'm just downloading the updates for the PB now, so I'll see what happens when that is upgraded.

    Thanks for the help anyway guys.

Share This Page