Struggling to get photos from Time Machine Back-ups (old Macbook Snow Leopard, new MBP Yosemite)

Discussion in 'OS X Yosemite (10.10)' started by rarchy, Aug 28, 2015.

  1. rarchy macrumors newbie

    Joined:
    Oct 4, 2010
    #1
    Aaaaaggghhhhh I am getting so frustrated with Time Machine and getting documents from a previous back up, why do Apple have to over complicate everything!

    I have a new Macbook Pro running on OS X Yosemite. I have files from an old macbook which I would like to access and put onto my new laptop. I don't need everything, just want to select certain parts - currently the main priority is photos. My old laptop was pretty old, from around 2007 and I think it had Snow Leopard. It died a while ago so I am using the old back ups to get some files.

    I am having the following issues:

    - When I plug in the hard drive with my time machine back ups on and go to "enter time machine" it does not show any of my old back ups - maybe this is down to it being different OS?

    - When I go to finder and open time machine, it does show my old laptop name and if I wait it eventually shows the previous back-ups, then if I wait for a lot longer it does show different folders like Applications but I can never get it to show actual files

    - I tried using Migration Assistant and had more issues:
    -> first of all it says the last back up was Jan 2014, when in fact it was March 2014 (this is strange as when I access time machine in finder it shows the last back up as March 2014).
    -> Nevertheless I then go through and select just photos, it comes up saying there is already a user with my name - of course there is as I am the same person!! I don't want to create a new user account, I want to put the files from my old laptop onto my new one. However there i no way around this so I follow the instructions, give the old account a new name etc.
    -> Then it transfers, goes to the log in page and it has created a whole new user. If I open up under my normal current user it does not show me any of the files I have just attempted to transfer, if I open up the old user account its as if another person is using the laptop
    -> I go to photos and it gives me the option to select my old photo library, however it says it is out of date and needs to be updated, but does not give any instructions on how - useless!
    -> I notice it has also transferred a lot of other stuff including apps, even though I only selected photos - again useless!

    I am sorry to be ranting but this is really frustrating. I am not an expert on computers, but nor am I am idiot so it should not be so difficult to understand - why do Apple make everything so damn complicated. I am sure if I have windows I could just open the old files and drag and drop whatever I wanted, i.e. music, photos etc. I love Apple products but why do they always make everything harder than it needs to be :(

    I understand I am trying to access files from an older version, however I just want things like photos and music and this should still be compatible right?

    If anyone can offer any help to the below I will be very grateful:

    1) How I can get photos
    2) How I can do it without creating a second user

    Many thanks

    Rachel
     
  2. rarchy thread starter macrumors newbie

    Joined:
    Oct 4, 2010
    #2
    Update - on Finder I can get it to show more folders if I wait even longer - when I go to the last back up it has "Applications", "Library", "System" and "Users" - I opened up library and after 10 mins or so it showed up lots of folders, however none seemed to be linked to photos, I tried opening iTunes and again waiting for a long time it just showed one plug in.

    Does anyone know if I can locate old files this way and if so where they would be (photos)?
     
  3. !!! macrumors 6502

    !!!

    Joined:
    Aug 5, 2013
    #4
    You should use Migration Assistant.
    You can choose which files you want transferred using this app. It's located in /Applications/Utilities.
    The reason the backups aren't showing when you enter time machine is because they are from a different mac. I would reset the new Mac, set it up, then when it asks you if you want to Transfer from Time Machine, then plug in your HD, and select the files you want restored.
     
  4. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #5
  5. rarchy thread starter macrumors newbie

    Joined:
    Oct 4, 2010
    #6
    Thanks for the replies

    Steve - trying this now, seems to be showing something, problem is it takes so long to open any thing so it keeps freezing but I may be getting somewhere with this, at least for the photos

    !!! & Coastal - I have tried Migration Assistant and listed in my post the problems I had with it, it doesn't seem to let me just select the files I want, I have to set up a new user account and even then can't access what I want.
     

Share This Page