Stubborn song in iTunes (1 of 29 from a single album)

Discussion in 'Mac Apps and Mac App Store' started by Ninja Football, Dec 19, 2010.

  1. Ninja Football macrumors newbie

    Joined:
    Jun 27, 2010
    #1
    Hey all. I recently downloaded a flac playlist of a live show I attended last year, and yesterday was updating all the info on the album. There are 29 tracks, all listed as #x of 29 in the get info section of each, and each with the same album and artist info (copied and pasted exactly).

    Anyway, #16 of 29 shows up as not being part of the album. I've erased the get info labels and re-labeled, I've tried deleting it from iTunes and reloading the track, nothing works. I'm sure I'm overlooking something simply, but I'm kinda new, so any help would be greatly appreciated.

    Thanks in advance!
     
  2. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #2
    Album artist field and artwork identical in all of them as well? What about Disk 1 of 1? Sometimes, some stubborn albums need to be tagged as compilations to merge... and very occasionally, then untagging them as compilations sometimes keeps them together.

    Just slowly working through re-ripping my entire collection to lossless over the coming months and years, fixing tags and artwork, so know where you're coming from. Selecting all the tracks at the same time and editing the universal fields for artist, album artist, track numbers, album title, disk number is a little more foolproof and faster than copying and pasting the same info into fields one by one.
     
  3. Kyffin macrumors 6502

    Joined:
    Sep 5, 2010
    #3
    Even with this some can be stubborn- I know it should work but sometimes it just doesn't. As a last resort have you tried selecting the whole lot and in the right-click menu 'consolidate files'? Haven't figured a silver bullet on this one but it can be done with tinkering. Good luck!
     
  4. Ninja Football thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #4
    Thank you!

    I tried both Disk 1 of 1 and marking it as a compilation, and one of those worked. Thanks for your help, I'd been trying different things for an hour or so.

    Also, the moving of the thread was noted (oops :rolleyes:), as I'm sure I'll be around more.
     

Share This Page