Substantial Battery drain with lid closed

Discussion in 'macOS Mojave (10.14)' started by colb2019, Mar 16, 2019.

  1. colb2019 macrumors newbie

    Joined:
    Mar 12, 2019
    #1
    I've been having an issue in the last few weeks with huge battery drain when I close the lid and MacBook (AIR circa mid-2014) enters sleep mode. I have read some threads on here that it has been happening to people since Mojave update. On the day it started to occur I didn't do anything out of the ordinary apar from connect to a new network - which I have since removed.

    Have tried all the normal suggestions SMC /PRAM reset, fresh install of Mojave and have changed various power settings like TCPKeepalive and Hibernate mode to 25. Nothing has worked and it'd driving me crazy.

    Checking to see if anyone still has this issue? Have you just accepted it and shut down each time. This is really annoying as shutting down and restarting so many times during the day becomes very tedious and frustrating, when previously all I needed to do was close the lid!
     
  2. Honza1 macrumors 6502

    Joined:
    Nov 30, 2013
    Location:
    US
    #2
  3. colb2019 thread starter macrumors newbie

    Joined:
    Mar 12, 2019
    #3
    Have gone through the link without any success. Have googled issue and tried all solutions and nothing makes a difference. No issue with lid that I'm aware of but will look into that further. Yes, 10-15% per hour is not normal.
     
  4. colb2019 thread starter macrumors newbie

    Joined:
    Mar 12, 2019
    #4
    Doesn't seem to be a problem with the lid, but when I listen closely when lid is closed it seems as if something is running, there is a spinning like noise and a faint beep noise now and again.
     
  5. Honza1 macrumors 6502

    Joined:
    Nov 30, 2013
    Location:
    US
    #5
    Not completely familiar with this Air, I am pretty sure it has SSD and so the only thing which can make any noises are fans. If the fans do not ever power down, then the system is not sleeping. Display may power off, but system not. Normally I would suggest reset SMC/PRAM, but you said you reset those and even installed fresh Mojave. Did you install clean (on reformatted drive) or just over existing system?
    It may be worth wipe the drive and install plain vanilla clean Macos, if you have not done that. Test without any user software.
    In any case, if the fans are not going off, you will be loosing power... If it happens on clean system and after reset of SMC/PRAM, I wonder if it is something in hardware. It may fall into "Take it to Apple" category.
     
  6. icymountain macrumors 6502

    Joined:
    Dec 12, 2006
    #6
    I recently had similar problems, and it seems that they are solved now, thanks to a change of the hibernate mode settings.

    In the terminal the
    Code:
    pmset -g
    command displays the main power management parameters. In my case, the value of hibernatemode was 0. I did set it to 25:

    Code:
    pmset hibernatemode 25
    For more information: https://www.lifewire.com/change-mac-sleep-settings-2260804
     
  7. Kaydin macrumors member

    Joined:
    May 14, 2011
    #7
    I have encountered this issue and I even contacted Apple to work together on finding what's broken. My findings are that if you turn off Wi-Fi, Bluetooth and you turn on Do Not Disturb mode, the drain will stop. I tested this for a few days and it's working great! While this is the same "band-aid" fix like changing the hibernatemode to 25, this doesn't address the real issue. Hibernation actually removes the power from RAM, as well, turning off the computer. The fix that I worked out doesn't require changing hibernatemode, since it stops the Mac from waking up while in sleep. The issue is related to Enhanced Notifications. Hopefully, Apple will do something about it. I already have an Apple Case Number and have discussed via phone and e-mail with them. Waiting for them to fix the real issue, since you shouldn't have to turn off features for the Mac to sleep properly. Somehow, Enhanced Notifications doesn't respect the Energy Saver settings (Power Nap, especially) and does its thing in the background. Turning off Wi-Fi, Bluetooth and turning on Do Not Disturb mode turns off Enhanced Notifications.

    Let me know if this worked out for you, as well.
     

Share This Page

6 March 16, 2019