Sudden crash (shutdown) 5 minutes into playing games on Windows Vista and 7

Discussion in 'Windows, Linux & Others on the Mac' started by Stormwolfski, May 10, 2009.

  1. Stormwolfski macrumors newbie

    May 5, 2009
    Running on a MacBook Pro (MacBookPro1,1).

    I've installed Windows 7 RC (build 7100), and installed the Boot Camp drivers (2.0, then updated to 2.1). Everything runs as expected, until I try to play any graphics intensive games (tried this with Civilization IV and Red Alert 3). I get the same problem under Windows Vista.

    About 5 minutes into the game, the machine crashes/shutdown as if it's suddenly lost power (i.e., it's fine and then *poof* it's off, with the usual sort of sound you get at the end of a shutdown).

    I don't have any issues like this running OS X (10.5.6), and didn't previously with installs of XP, although that was maybe a year ago. Not sure if it occurs running XP now.

    I've tried installing the newest drivers for the ATI X1600 from the ATI website, and changing the clock speed (read this on some forum) using ATITool, but no change.

    I'm really at a loss at what to try next.
  2. StrayRooster macrumors member

    Mar 19, 2007
    I have the exact same problem. Can't run any Steam games without a crash. Bioshock doesn't even get past the loading logo, while all my source games crash about 20 seconds in.

    I updated the Nvidia driver, but still no luck. I'm lost as well.

    Running 32bit windows 7 RC1, 15'' aluminum MBP.
  3. Stridder44 macrumors 68040


    Mar 24, 2003
    Heat issue? I mean the fans are going full bore whenever you open the games right?
  4. Timur macrumors 6502a


    Oct 14, 2008
    More likely either a Windows 7 issue, maybe in combination with the Mac, or in case of an NVidia graphic based Mac an issue with switching performance levels during the game. I don't know about ATI based Macs though.

    Use Rivatuner to fix the performance level to "Performance 3D" and try the game again.

    I've been running hours of Civilization IV on Vista 64 without problems and hours of Prime95 at 100°C CPU temperature without any errors. Both the CPU and GPU have specs of 105°C btw on the Nvidia based Macs, guess the ATI ones ain't far away from that either, so forget about heat issues unless your Mac is faulty.

    You can also try to disable/kill KBDMGR.EXE via Task-Manager and/or disable the Trackpad driver.
  5. Bill Gates macrumors 68020

    Bill Gates

    Jun 21, 2006
    Disable the option to automatically power down upon a system failure in order to find out why the system is crashing.

    Right-click on My Computer and choose Properties.
    Click on Advanced system settings
    Choose the Advanced tab and click Settings where it says "Startup and Recovery"
    Uncheck the box that says "Automatically Restart" under the words "System failure" and click "OK"
  6. Shorties macrumors 6502a

    Jul 22, 2007
    Southern California
    I hate to bring up an old thread but I am having the exact same issue on Vista x86 Home Premium, anyone found a fix yet?

    I did that and it still crashed, with no warning or explanation. I have no issues on OSX.

Share This Page