Resolved Switching phones. How to turn off sending using iMessage

Discussion in 'iPhone' started by 3bs, Mar 4, 2012.

  1. 3bs, Mar 4, 2012
    Last edited: Mar 6, 2012

    3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #1
    If I want to sent texts to someone who switched from an iPhone to any other phone, what do I have to do so that my iPhone doesn't think they are still on iMessage?

    Edit: turning off iMessage on the iPhone worked. Deleting it from the registered products list linked to the Apple ID as suggested on an Apple thread didn't work.
     
  2. Sirobin macrumors 6502

    Sirobin

    Joined:
    May 6, 2008
    Location:
    California
    #2
    It’ll do it automatically, don’t worry about it.
     
  3. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #3
    If that was the case then I wouldn't have started the thread. I've tested it out and it won't.
     
  4. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #4
    Apparently that poster hasn't read the million other threads about this!
     
  5. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #5
    So the solution posted at the top of the thread didn't work
     
  6. Indecisi0n macrumors regular

    Indecisi0n

    Joined:
    Feb 19, 2012
  7. dave420 macrumors 65816

    Joined:
    Jun 15, 2010
    #7
    If it happens automatically then why do we have numerous front page articles talking about people not being able to turn it off? I could probably link to 15 different threads describing the problem in the iPhone and iOS forums as well. None that I have seen have a clear solution.
     
  8. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #8
    What do you mean? :p

    I tried turning off iMessage and texting and it did send as a text but after turning iMessage back on it went back to trying to send using iMessage
     
  9. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
  10. dave420 macrumors 65816

    Joined:
    Jun 15, 2010
    #10
    Can they switch back to their old iPhone temporarily and turn off iMessage? Otherwise you may just have to hold down the text message after you send it and choose the send as text option to avoid the delay.
     
  11. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #11
    I'll give that a try and report back.
     
  12. reclusive46 macrumors 65816

    reclusive46

    Joined:
    Apr 14, 2011
    Location:
    Canada
    #12
    Try deleting the whole text message thread and make a new one and try and send them one. Normally works for me.
     
  13. Cod3rror macrumors 68000

    Cod3rror

    Joined:
    Apr 18, 2010
    #13
    Design and build a time machine, go back in time and shoot his grandfather.

    That should fix it.
     
  14. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #14
    Tried that but it didn't. Turning off iMessages on the iPhone worked!

    Too late, already fixed it. I'll do this with the next person who decides to switch phones.
     
  15. sentinelsx macrumors 68010

    Joined:
    Feb 28, 2011
    #15
    Strange. My phone automatically switches from iMessage to normal text messages if the other person is not using data/wifi (switched off etc) or have a different phone and switches back to imessage when internet is available or if it detects an iPhone. I never had this issue.
     

Share This Page