System preferences software update badge

amok-san

macrumors member
Original poster
Mar 12, 2008
57
14
Is there a way to get rid of the red badge on the system-preferences icon that reminds me of the Catalina update?

Edit: I tried "sudo softwareupdate --ignore 'macOS Catalina'" and the update is being ignored but the badge still stays.
 
  • Like
Reactions: navaira and bernuli

bogdanw

macrumors 6502
Mar 10, 2009
266
158
Is there a way to get rid of the red badge on the system-preferences icon that reminds me of the Catalina update?
Edit: I tried "sudo softwareupdate --ignore 'macOS Catalina'" and the update is being ignored but the badge still stays.
Try
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs; killall Dock
 

amok-san

macrumors member
Original poster
Mar 12, 2008
57
14
That does it!

At least as long as you don't click on "Software-update" again...

Good enough, thank you!
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,475
8,685
Ventura County
That does it!

At least as long as you don't click on "Software-update" again...

Good enough, thank you!
Mine came back after about 5 hours. I have auto-update off and all that jazz. This little badge is going to annoy me. I can't believe there isn't a notification toggle for settings.
 

Tech198

macrumors G5
Mar 21, 2011
13,944
1,636
Australia, Perth
Try
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs; killall Dock

This work, but before you do it uncheck "Check for updates" in Advanced.

As just going to Software update auto checks and it will come back anyway.
So, after to uncheck the option and run the above, don't manually check again, unless you want to.

I've only just done this, so i'll see if it comes back, worth a shot.

I think this is gonna run into a dead end.. there is pobably no way to only check for "some" but not "all" updates.. Either none or all.
 

Attachments

Last edited:

bogdanw

macrumors 6502
Mar 10, 2009
266
158
Edit: I tried "sudo softwareupdate --ignore 'macOS Catalina'" and the update is being ignored but the badge still stays.
Catalina is not an update, it doesn't show when you run softwareupdate -l
Once it was available, it was written into /Library/Preferences/com.apple.SoftwareUpdate.plist as LastRecommendedMajorOSBundleIdentifier = "com.apple.InstallAssistant.Catalina"
I tried with sudo softwareupdate --ignore com.apple.InstallAssistant.Catalina , but it didn't work.
Any other ideas?
 

mcaswell

macrumors regular
Dec 22, 2013
219
92
I have no plans to upgrade to Catalina (Mojave is working fine for me, and I have some 32bit apps I'm not willing to let go of yet). Is there a way to stop System Preferences from showing this update badge?


Screen Shot 2019-10-08 at 1.45.31 PM.png Screen Shot 2019-10-08 at 1.45.01 PM.png
 
  • Like
Reactions: golfnut1982

chabig

macrumors 603
Sep 6, 2002
5,876
3,133
I don't think you can remove that badge. So if it bothers you a lot, just take System Preferences out of your dock.
 
  • Like
Reactions: xgman

BarryDuffman

macrumors newbie
Jul 20, 2011
23
3
Copenhagen, Denmark
I have no plans to upgrade to Catalina (Mojave is working fine for me, and I have some 32bit apps I'm not willing to let go of yet). Is there a way to stop System Preferences from showing this update badge?
I think I found a way. :)
In Terminal you can hide the update so it doesn't show in Software Update. This way you do not install it by error, or overlook other updates for Mojave.
In my case I was presented with an update window like the OPs, but with a tiny notification that there were other updates (for Mojave).

To hide the update copy/paste into Terminal:
sudo softwareupdate --ignore "macOS Catalina"

Now the badge remained in System Preferences in the dock and in the Apple menu in the upper left it still showed "1 update" next to System Preferences.

After some searching on the Internet I found this command to hide/reset the badge and Apple menu notification.
defaults write com.apple.systempreferences AttentionPrefBundleIDs 0
Followed by
killall Dock

I write hide/reset, as I am not 100% sure if it just resets the notification counter or it completely hides any future notification. Only time will tell. So use at your own risk. But now that annoying notification is gone.
Maybe others can elaborate on what the defaults write command does excactly ;)

EDIT: If you want the Catalina update back you should be able to with this command. I haven't tried it myself though.
sudo softwareupdate --reset-ignored

EDITEDIT: Specified who I was replying, after thread merge
 
Last edited:
  • Like
Reactions: avz and mcaswell

revenire

macrumors member
Mar 6, 2011
64
14
I unchecked "check for updates" and used "defaults delete com.apple.systempreferences AttentionPrefBundleIDs; killall Dock" = so far, so good. Thanks.
 
Last edited:

avz

macrumors 6502a
Oct 7, 2018
582
800
I think I found a way. :)
In Terminal you can hide the update so it doesn't show in Software Update. This way you do not install it by error, or overlook other updates for Mojave.
In my case I was presented with an update window like the OPs, but with a tiny notification that there were other updates (for Mojave).

To hide the update copy/paste into Terminal:
sudo softwareupdate --ignore "macOS Catalina"

Now the badge remained in System Preferences in the dock and in the Apple menu in the upper left it still showed "1 update" next to System Preferences.

After some searching on the Internet I found this command to hide/reset the badge and Apple menu notification.
defaults write com.apple.systempreferences AttentionPrefBundleIDs 0
Followed by
killall Dock

I write hide/reset, as I am not 100% sure if it just resets the notification counter or it completely hides any future notification. Only time will tell. So use at your own risk. But now that annoying notification is gone.
Maybe others can elaborate on what the defaults write command does excactly ;)

EDIT: If you want the Catalina update back you should be able to with this command. I haven't tried it myself though.
sudo softwareupdate --reset-ignored

EDITEDIT: Specified who I was replying, after thread merge
Thanks! This worked on my MacBook5,1.
 

xgman

macrumors 601
Aug 6, 2007
4,777
606
I've learned to ignore it because I want to see the other updates and may eventually let it update to cat... eventually, but no time soon.
 

golfnut1982

macrumors regular
Oct 12, 2014
194
49
Chicago, IL
Just to be sure, Catalina won't automatically upgrade on its own right? Because right now in advanced, I have install Mac OS updated not checked. I realize this is not good while on Mojave, so I want to change it back. Please advise.

I'm not updating yet because I'm not ready to give up on some of my 32 bit stuff.
 

mpfuchs

macrumors 6502
Sep 19, 2014
484
1,234
VA
So how do you get an update to Mojave if all it's showing now is Catalina?
I know I had an update I hadn't installed before the release of Catalina, but i can't seem to find it now...
 

dsemf

macrumors 6502
Jul 26, 2014
330
67
So how do you get an update to Mojave if all it's showing now is Catalina?
I know I had an update I hadn't installed before the release of Catalina, but i can't seem to find it now...
Look for the small More Info under the Catalina section. The More Info in the Catalina section takes you to the Apple web page for Catalina.

DS
 

bogdanw

macrumors 6502
Mar 10, 2009
266
158
So how do you get an update to Mojave if all it's showing now is Catalina?
I know I had an update I hadn't installed before the release of Catalina, but i can't seem to find it now...
If you run
Code:
sudo softwareupdate --ignore 'macOS Catalina'
Catalina should be hidden and Mojave updates should be visible.
 

bogdanw

macrumors 6502
Mar 10, 2009
266
158
EDIT: See https://forums.macrumors.com/threads/system-preferences-software-update-badge.2204123/post-27869914

I think there may be a permanent solution, but it might have unintended consequences.
Here are the steps
Code:
sudo softwareupdate --ignore 'macOS Catalina'
defaults delete com.apple.systempreferences AttentionPrefBundleIDs
defaults delete com.apple.systempreferences DidShowPrefBundleIDs
defaults write com.apple.systempreferences AttentionPrefBundleIDs -dict com.apple.preferences.softwareupdate -float 0
sudo chown root:wheel ~/Library/Preferences/com.apple.systempreferences.plist
killall Dock
and restart.
So, ignore Catalina, delete the notification, set notification to 0 for softwareupdate and change ownership of com.apple.systempreferences.plist so that it can't be modified by the user.
 
Last edited:

i486dx2-66

macrumors member
Feb 25, 2013
31
8
I think there may be a permanent solution, but it might have unintended consequences.
Just to be specific, at least one of the unintended consequences would be that Software Update would never again show any notifications for future Mojave updates... correct?
 

J. J.

macrumors regular
Oct 15, 2012
119
5
For anybody interested, I found a way to disable the badge on System Preferences icon and to prevent it from coming back without having to mess with file permissions. However this only works of you have disabled System Integrity Protection (SIP). Also, do not use sudo for any of these commands.

If you want to temporarily turn off the badge (until next reboot) run the following command:
Code:
launchctl unload /System/Library/LaunchAgents/com.apple.softwareupdate_notify_agent.plist

If you want to turn off the badge and you want the setting to persist even after a reboot run:
Code:
launchctl unload -w /System/Library/LaunchAgents/com.apple.softwareupdate_notify_agent.plist

Finally, in both cases, run the commands mentioned above:
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs; killall Dock

If you want to undo the change and go back to normal just run the same command as before replacing unload with load. The badge will reappear the next time you (or the system) check for updates.
 
Last edited:

sgtaylor5

macrumors regular
Aug 6, 2017
137
59
Cheney, WA, USA
For anybody interested, I found a way to disable the badge on System Preferences icon and to prevent it from coming back without having to mess with file permissions. You may need to disable System Integrity Protection (SIP), tho.

If you want to temporarily turn off the badge (until next reboot) run the following command:
Code:
launchctl unload /System/Library/LaunchAgents/com.apple.softwareupdate_notify_agent.plist

If you want to turn off the badge and you want the setting to persist even after a reboot run:
Code:
launchctl unload -w /System/Library/LaunchAgents/com.apple.softwareupdate_notify_agent.plist

Finally, in both cases, run the commands mentioned above:
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs; killall Dock

If you want to undo the change and go back to normal run:
Code:
launchctl load -w /System/Library/LaunchAgents/com.apple.softwareupdate_notify_agent.plist
The badge will reappear the next time you (or the system) check for updates.
When I ran command #2 (persist after reboot), Terminal complained about SIP. When I reran the command with sudo at the beginning and entered my system password, Terminal complained it couldn't find the file (I think it had been already unloaded). I entered the defaults command.

After I rebooted, the badge was still there, but the "1 Update" bubble in the Finder menu after System Preferences had vanished. And, that was my goal. I have "macOS Updates" OFF in Software Update; just won't check Software Update again. I've already immunized the /Library/Bundles folder from ever having the OSNotification.bundle file work again. That's about the best I can do.